Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

Drive belt


  • Please log in to reply
13 replies to this topic

#1 BIG RUH OFFLINE  

BIG RUH
  • Member
  • Member No: 78794
  • 14 Thanks
  • 27 posts
  • Location: Waterloo, IL.

Posted February 14, 2017 - 02:54 PM

I have a # 12 Massey Ferguson garden tractor. Does anyone have a photo or diagram of how the drive belt is installed on a #12 hydro speed.

Thanks

Steve



#2 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 50463 Thanks
  • 52446 posts
  • Location: Collinsville, Oklahoma

Posted February 14, 2017 - 03:21 PM

:wave: Just wanted to welcome you to the forum. Folks will be along with help soon.


  • DMAX said thank you

#3 fignasiak OFFLINE  

fignasiak
  • Member
  • Member No: 53386
  • 11 Thanks
  • 9 posts
  • Location: Denver, Co

Posted March 12, 2017 - 12:09 AM

Hello,

 

I just bought a Hydro 12 also. The belts are a mess and the 'spare parts' that came with it include some pulleys. Just wanting to know if this question was answered (and where I can find it). Also looking for any manuals too. I saw the ones for the gear models and the per-delivery ones.



#4 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 50463 Thanks
  • 52446 posts
  • Location: Collinsville, Oklahoma

Posted March 12, 2017 - 05:34 AM

I guess not. I'm no Massey guru. but I may have to take a stab at this.



#5 esbbent OFFLINE  

esbbent

    New Member

  • Senior Member
  • Member No: 1183
  • 537 Thanks
  • 357 posts
  • Location: Colfax IA

Posted March 12, 2017 - 08:42 AM

Download the MF10-12 Service Manual from this site, it has a picture of the belt at the back of the machine. The AGCO partsbook for the MF12 has a diagram for the Hydro belt routing and may help you identify the other pulleys you have.


  • KennyP and fignasiak have said thanks

#6 fignasiak OFFLINE  

fignasiak
  • Member
  • Member No: 53386
  • 11 Thanks
  • 9 posts
  • Location: Denver, Co

Posted March 12, 2017 - 02:25 PM

Thanks, I was able to find the rear routing part in the service manual. I have yet to be successful at getting the AGCO partsbooks to find these older models. Have any tips on how to make it work? I though there was a post on how to use that site but I cannot find it.

 

I also suspect the tensioner has been beat up a bit and the mount bent. I was hoping someone might have a picture of that, preferably from the side.


Edited by fignasiak, March 12, 2017 - 02:29 PM.


#7 esbbent OFFLINE  

esbbent

    New Member

  • Senior Member
  • Member No: 1183
  • 537 Thanks
  • 357 posts
  • Location: Colfax IA

Posted March 12, 2017 - 03:40 PM

For the partbooks-Agcopartsbooks.com by guest user press "view Books", then put 12 in for model number and change the drop down box from all brands to Massey Ferguson. There will be a list of the model 12's for Massey, press 12 Tractor. The parts book will open up, on the left under title press the "drive idler conversion kit" it will bring up the belt, pulleys,  and brake parts. I can't get the picture from the parts book to copy and past here.

 

The MF12 I have is variable speed not a hydro, so I don't have a tensioner to look at or take a picture for you.


  • DMAX, KennyP and fignasiak have said thanks

#8 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 50463 Thanks
  • 52446 posts
  • Location: Collinsville, Oklahoma

Posted March 12, 2017 - 06:10 PM

For the partbooks-Agcopartsbooks.com by guest user press "view Books", then put 12 in for model number and change the drop down box from all brands to Massey Ferguson. There will be a list of the model 12's for Massey, press 12 Tractor. The parts book will open up, on the left under title press the "drive idler conversion kit" it will bring up the belt, pulleys,  and brake parts. I can't get the picture from the parts book to copy and past here.

 

The MF12 I have is variable speed not a hydro, so I don't have a tensioner to look at or take a picture for you.

Is this what you wanted to show?

ScreenShot116.jpg


  • fignasiak said thank you

#9 fignasiak OFFLINE  

fignasiak
  • Member
  • Member No: 53386
  • 11 Thanks
  • 9 posts
  • Location: Denver, Co

Posted March 13, 2017 - 03:46 PM

Okay I just dug into it. Looks like my problem may be a worn out belt and some bad idlers.  I have attempted to attach a few pictures to 'enrich' this thread for others (hope they work). I would appreciate feed back on the tensioner issue here. Looks somewhat custom made but maybe the tab is just bent back? I know that it is bent a little and probably installed incorrectly at the moment. Only the back ear catches right now.

 

And sorry for taking over on this thread :hijacked:

 

IMG_4070.JPG IMG_4071.JPG IMG_4072.JPG


Edited by fignasiak, March 13, 2017 - 04:00 PM.

  • limebuzz said thank you

#10 Jspies22 OFFLINE  

Jspies22
  • Member
  • Member No: 100258
  • 6 Thanks
  • 15 posts
  • Location: Minneapolis

Posted September 02, 2020 - 05:23 PM

Did anyone ever reply to this thread? Having a similar problem with a MF 12 I just purchased. Diagrams help but pictures are better. I’m not sure if mines missing parts or how things are supposed to be put back together.

#11 Jspies22 OFFLINE  

Jspies22
  • Member
  • Member No: 100258
  • 6 Thanks
  • 15 posts
  • Location: Minneapolis

Posted September 02, 2020 - 05:23 PM

Did anyone ever reply to this thread? Having a similar problem with a MF 12 I just purchased. Diagrams help but pictures are better. I’m not sure if mines missing parts or how things are supposed to be put back together.

#12 esbbent OFFLINE  

esbbent

    New Member

  • Senior Member
  • Member No: 1183
  • 537 Thanks
  • 357 posts
  • Location: Colfax IA

Posted September 02, 2020 - 08:30 PM

Did anyone ever reply to this thread? Having a similar problem with a MF 12 I just purchased. Diagrams help but pictures are better. I’m not sure if mines missing parts or how things are supposed to be put back together.

I do not think anyone replied to the thread. The first picture from the post 3/13/17 the belt is routed correctly. The issue was the spring tensioner is bent (pic 2) the spring tensioner outside case has 2 ears that fit in the bracket with the notches. The brackets were not made strong enough IMO, I had to fix the one on my 12H. 



#13 Jspies22 OFFLINE  

Jspies22
  • Member
  • Member No: 100258
  • 6 Thanks
  • 15 posts
  • Location: Minneapolis

Posted September 04, 2020 - 11:07 AM

I was able so piece mine together from the bucket of spare parts that came with mine. Here are some pics.

#14 Jspies22 OFFLINE  

Jspies22
  • Member
  • Member No: 100258
  • 6 Thanks
  • 15 posts
  • Location: Minneapolis

Posted September 04, 2020 - 11:29 AM

Here is some pictures of the drive belt on my mf12 hydro. The idler pulley isn’t correct but is is working for the time being.

Attached Thumbnails

  • 71057869-7E70-44E5-9DB9-83F82F43445F.jpeg
  • AEEC14D1-702D-4D19-B2E0-B6E522606BC9.jpeg
  • E9AA7445-B11D-4AE0-BE97-4A411B9B7C6A.jpeg
  • image.jpg

Edited by Jspies22, September 04, 2020 - 11:30 AM.





Top