Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

John Deere RX95 Variator problem?


  • Please log in to reply
1 reply to this topic

#1 Edward OFFLINE  

Edward

    New Member

  • New Member
  • Member No: 7611
  • 0 Thanks
  • 1 posts

Posted November 29, 2011 - 07:27 PM

Hi all,

The reverse and forward speeds 1-5 suddenly quit working on my RX-95, but speed 6 and 7 still functioned. I replaced both the primary and secondary belts with new John Deere belts. I followed the service manual to the "t", triple checked my belt routings, and went thru the procedure for adjusting the speed control linkage. Now I have reverse and speeds 2-7, but all the forward speeds are the same (very slow). Speed setting 1 does nothing. All this leads me to the variator (I think). The problem is that I can move the center up and down with my fingers, so it's not siezed. It's not easy to move, but it does move. How free should the center of the variator be; should this be lubed, and it so, how and with what? I'm stumped.

Any advice would be greatly appreciated,

Ed

#2 JDBrian OFFLINE  

JDBrian

    Super Moderator

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2507
  • 9,574 Thanks
  • 14,136 posts
  • Location: Hubley, Nova Scotia - Canada

Posted November 30, 2011 - 11:06 AM

Welcome to GTTalk Edward. I don't have any knowledge ofthe Variator in question. If you give it some time someone may respond who has more specific knowledge.




Top