Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

Toro Starter/Generator Troubles... ugh

  • Please log in to reply
No replies to this topic

#1 wvbuzzmaster OFFLINE  


    Squeaky Wheel

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 1792
  • 4,492 Thanks
  • 7,341 posts
  • Location: West Virginia

Posted November 13, 2011 - 05:28 PM

Well, today I dug into the Toro to see if I couldn't cook two geese with one BBQ, and I came up short. The Toro has not been charging for some time and I decided that the recent discovery of the spaced out starter brackets was as good a time as any to fix both issues. So I downloaded my article to refresh my Starter/Generator testing memory and went to test that first... Well... The armature nut had to be cut off with the Dremel as it stripped the stud as soon as I turned it!! So after I got those off I went to test the Starter/Generator. Well, the test went fine... except the Starter/Generator is the issue, so it will need some work, hopefully new brushes... and a new stud.. So on to the bracket, the easy part, took the stack of washers they had between the block and lower S/G bracket out and bolted the bracket on as it should be, against the block. I decided to take the guard off to straighten it out (it was reshaped to accommodate the wrong size belt). I took it to the anvil and proceeded to straighten it, success, so then I decided to paint it, will have to sand it tomorrow and add another coat though. I at least put the new belt on... but the S/G is still off. Hopefully this week I can get it sorted out...