Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Just bought a 332


  • Please log in to reply
20 replies to this topic

#1 ldone OFFLINE  

ldone

    New Member

  • New Member
  • Member No: 6509
  • 0 Thanks
  • 9 posts

Posted October 12, 2011 - 10:03 PM

Bought as is, does not run, but cranks good....is getting fuel ok, sprayed wd40 in air intake but no luck........any ideas?

#2 Gibby OFFLINE  

Gibby

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 4886
  • 96 Thanks
  • 360 posts
  • Location: Butler County, Pa

Posted October 12, 2011 - 10:15 PM

Does it have spark?

#3 ldone OFFLINE  

ldone

    New Member

  • New Member
  • Member No: 6509
  • 0 Thanks
  • 9 posts

Posted October 12, 2011 - 10:22 PM

Uh!.........help me out here........how does a diesel have spark? It does not try to start.....only cranks nicely

I know that the glo plug light works and goes off after a short period of time

#4 Gibby OFFLINE  

Gibby

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 4886
  • 96 Thanks
  • 360 posts
  • Location: Butler County, Pa

Posted October 12, 2011 - 10:37 PM

My bad, I'm not sure what you would check on a diesel other than if it's getting fuel. Maybe compression?

#5 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,371 Thanks
  • 39,644 posts
  • Location: Collinsville, Oklahoma

Posted October 13, 2011 - 04:46 AM

Welcome, Idone! I'm like Gibby, if it doesn't have spark plugs, I don't know what the heck could be wrong with it. Maybe the injector pump is out of time?

#6 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 13, 2011 - 08:51 AM

Any white smoke while cranking? Electric fuel pump working? Had to replace the electric fuel pump on my 330 not long after I got it home. Tons of power but wish it had a hi/low range like the 400 series.

#7 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,568 Thanks
  • 29,820 posts
  • Location: South Central Kentucky

Posted October 13, 2011 - 09:07 AM

Put your hand over the intake while cranking. It should suck hard on your hand. If not, then either the muffler is stopped up, or the valve timing is out of whack due to sheared timing key or the like, stuck valves, or just plain worn out rings. WD40 is not powerful used as a starting fluid (but engine safe), and if compression is very low it will not be volatile enough to fire the diesel. It takes VERY little true starter fluid in these little diesels and too much can damage the engine!

#8 JDBrian OFFLINE  

JDBrian

    Super Moderator

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2507
  • 9,574 Thanks
  • 14,136 posts
  • Location: Hubley, Nova Scotia - Canada

Posted October 13, 2011 - 10:17 AM

Congratulations on the new tractor. Have you checked to make sure the glow plugs are getting power. It sounds like the time delay relay is working but that doesn't guarantee they are heating.

#9 ldone OFFLINE  

ldone

    New Member

  • New Member
  • Member No: 6509
  • 0 Thanks
  • 9 posts

Posted October 13, 2011 - 11:01 AM

Thanks for the helpful replies........fuel pump is working, I "burped" the fuel filter.........intake seems to suck hard on palm of hand..........mild white smoke coming out of exhaust.......shot some ether into intake, did not make any difference........will ether work if glow plugs are not working? How do you test them?

Just discovered that the radiator is draining somewhere inside of engine.......not suppose to do that......and the breather hose is puffing when cranking

Edited by ldone, October 13, 2011 - 11:16 AM.
additional information


#10 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 13, 2011 - 11:17 AM

Glow plugs and either don't play well together. My glow plugs are disconnected (relay issue) so she gets a little shot of either when the engine is not at operating temp. Maybe loosen the fuel line at each injector to get any air out that may have gotten in there. You should see no bubbles.

#11 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,568 Thanks
  • 29,820 posts
  • Location: South Central Kentucky

Posted October 13, 2011 - 11:20 AM

Just discovered that the radiator is draining somewhere inside of engine.......not suppose to do that......and the breather hose is puffing when cranking


Sounds like you have a blown head gasket...worst case a cracked block or head.

#12 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 13, 2011 - 11:23 AM

Whoops, didn't see the part that was edited in...

#13 sgtrock1976 OFFLINE  

sgtrock1976

    Tractorholic

  • Senior Member
  • Member No: 6802
  • 4 Thanks
  • 111 posts

Posted October 13, 2011 - 12:09 PM

Keep thinking I want a diesel, but I know very little about gas engines and absolutely nothing about diesel engines. That's why this site is so important to me.

#14 ldone OFFLINE  

ldone

    New Member

  • New Member
  • Member No: 6509
  • 0 Thanks
  • 9 posts

Posted October 13, 2011 - 01:58 PM

dosen't sound good......think I will sell and let someone else fix it

#15 JDBrian OFFLINE  

JDBrian

    Super Moderator

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2507
  • 9,574 Thanks
  • 14,136 posts
  • Location: Hubley, Nova Scotia - Canada

Posted October 13, 2011 - 05:33 PM

Thats too bad. Before you commit to selling it consider having the engine looked at by an experienced diesel mechanic.




Top