Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

pictures of mf 10 in process

  • Please log in to reply
4 replies to this topic

#1 tomkuchenbrod OFFLINE  



  • Member
  • Member No: 5982
  • 6 Thanks
  • 39 posts
  • Location: close to Boonville,IN

Posted October 05, 2011 - 02:27 PM


These are the latest pictures of my mf 10 being primed. I have also included some pictures of the mf 10 and deck I got for $50.00 on ebay. I hope you enjoy.

Also, can you tell from the picture of the deck if I have all the mounting hardware or not. That is all that came with the deck.


Attached Thumbnails

  • mf107.jpg
  • lores six.jpg
  • lores four.jpg
  • mf105.JPG
  • mf104.jpg
  • lores five.jpg
  • mf106.jpg
  • lores two.jpg

Edited by tomkuchenbrod, October 05, 2011 - 02:29 PM.
brain fart

#2 mjodrey OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 92
  • 2,343 Thanks
  • 13,481 posts
  • Location: Upper Granville, Nova Scotia, Canada

Posted October 05, 2011 - 02:42 PM

Tom,thanks for the pics. You're doing a good job.
  • tomkuchenbrod said thank you

#3 mac102004 OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 1420
  • 200 Thanks
  • 319 posts
  • Location: Cape Breton, NS

Posted October 05, 2011 - 03:44 PM

There should be a bracket sticking up by where the gear box goes, with a slot in it. And a short rod shaped like " [ " that connects the deck to the lift handle. Do you have that?



    Electric Tractors

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 62
  • 4,498 Thanks
  • 5,266 posts
  • Location: Markham Ontario Canada

Posted October 05, 2011 - 04:59 PM

the red frame in the 3rd picture is a 66 frame, has extra engine mounting holes and if you look underneath you will find a missing center rib under where the engine sits.
The other frame is 67 and up.

#5 FirefyterEmt OFFLINE  



  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 610
  • 425 Thanks
  • 849 posts
  • Location: Northeast Connecticut

Posted October 05, 2011 - 05:41 PM

Looking at the deck, as stated, you are missing the bracket that the lift rod connects to. (And the gear box, this bracket bolts on with the gear box) You are also missing the main arms that go to the frame, however these are very easy to build. They are just flat stock with simple holes. The front, and maybve rear roller is missing too. I can't see the rear roller, but there is a part that looks like it goes to the rear roller on the ground. There should be two cast iron brackets that hold the rear roller in place too.

You do have the front mount plate, that is something that is easy to misplace with the deck, and alot harder to build!

Here is my restoration thread, some photos may be of help to you in there.
  • tomkuchenbrod said thank you