Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

MF10 Hood scraping on tank and battery- Variable Speed "updated" by previous owner


  • Please log in to reply
2 replies to this topic

#1 sacsr OFFLINE  

sacsr

    Bush Hog Addict

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 4776
  • 3,268 Thanks
  • 3,283 posts
  • Location: Eastern NC

Posted September 09, 2011 - 10:50 AM

Both of my mf10's hoods scrape (or get caught on) the tank and the battery.

I have tried to pull the sides out to "spring them out" some.....but has not worked. Anyone else have this issue and how did you fix it??

Have one hood off right now that was badly pitted and working on putty and sanding it.....

Found a few surprises on one of them......looks like someone had re drilled the hole on the variable speed hub assembley shaft...no longer left handed screw.......it was working so I guess I will leave it alone.

Anyone pulled the shaft on one of these?? Also these parts expensive?? It has caused a rut into the side of the outside pulley because it was not set upright.

thanks,

#2 tomkuchenbrod OFFLINE  

tomkuchenbrod

    Member

  • Member
  • Member No: 5982
  • 6 Thanks
  • 39 posts
  • Location: close to Boonville,IN

Posted September 15, 2011 - 12:47 PM

On my mf 10 I just bought, they busted the aluminum housing that the hood rests on. NOT RECOMMENDED. I am currently looking for a replacement for the busted "dash board". I honestly think the problem was that the batteries are bigger now than the used to be. The previous owner of mine also bent the battery seat to make room for a bigger battery. I know this doesn't help solve the problem but it does give me a chance to have some company with my misery.

#3 IamSherwood OFFLINE  

IamSherwood

    Elf guardian

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 2066
  • 8,379 Thanks
  • 7,696 posts
  • Location: Northern Ontario

Posted September 15, 2011 - 01:37 PM

Both of my mf10's hoods scrape (or get caught on) the tank and the battery.

I have tried to pull the sides out to "spring them out" some.....but has not worked. Anyone else have this issue and how did you fix it??

Have one hood off right now that was badly pitted and working on putty and sanding it.....

Found a few surprises on one of them......looks like someone had re drilled the hole on the variable speed hub assembley shaft...no longer left handed screw.......it was working so I guess I will leave it alone.

Anyone pulled the shaft on one of these?? Also these parts expensive?? It has caused a rut into the side of the outside pulley because it was not set upright.

thanks,



Shouldn't scrape on the tank or battery. Is the tank mounted in there correctly? There should be lots of room for both the battery and
tank if they're the correct ones.
Most of the hoods have an interference fit on the sides of the dash, which you pretty much need in order for it to latch properly.

Re shaft and pulleys. Pulled mine about a year ago, but can't recall if there where any tricks involved. Watch ebay for the sheaves, or see if you dig up
a parts buggy.


Tom sorry to hear about that broken aluminum dash. They are very hard to find. Are all the pcs there? Can you get it welded up?
  • sacsr said thank you




Top