Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

In-Line Primer for Fuel Pump (SS/16 Twin)

  • Please log in to reply
5 replies to this topic

#1 dthomp17 OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 2987
  • 480 Thanks
  • 409 posts
  • Location: Norcross Georgia

Posted September 01, 2011 - 08:50 PM

:smile1: I have a Sears SS/16 Twin that has the gas tank under the seat and a fuel pump that will lose its prime after sitting several days. Once it loses prime, I have to disconnect the gas line from the carburetor, attach a funnel with a gas line to the carb and start the engine from gas in the funnel. Then I disconnect the funnel and reconnect the gas line from the tank, usually spilling a little gas in the process. I have an old fishing boat with an outboard motor and remote gas tank. I happened to have an extra fuel line primer bulb for the boat. I decided to try this outboard primer bulb in the gas line from the tank to the carb to see if it would work. It worked great. Now when I lose prime, all I have to do is squeeze the bulb three or four times and I'm in business. This might work for you if you have similar problems.

  • Alc said thank you

#2 ncb OFFLINE  

  • Senior Member
  • Member No: 3755
  • 51 Thanks
  • 215 posts

Posted September 01, 2011 - 08:53 PM

Great idea, how about a few more pics of the GT, motor looks so clean

#3 dstaggs OFFLINE  


    In Remembrance, RIP Dale

  • RIP
  • -GTt Supporter-
  • Member No: 228
  • 552 Thanks
  • 1,781 posts
  • Location: Batesville, Arkansas

Posted September 01, 2011 - 09:11 PM

I have a GT rigged the same way. And was afraid to tell about thinking folks would laugh But it WORKS. And WELCOME to GTtalk and join some of us on chat.

#4 KennyP OFFLINE  



  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 27,617 Thanks
  • 38,996 posts
  • Location: Collinsville, Oklahoma

Posted September 02, 2011 - 04:01 AM

I just love the problem solving on this forum. Yeah, I laughed first. But if it works, use it.

#5 jwrezz OFFLINE  

  • Member
  • Member No: 80280
  • 0 Thanks
  • 1 posts

Posted January 29, 2016 - 02:50 PM

I just went to start my tractor for first time in weeks actually two months. Cranked for about 1.5 minutes until prime returned. This is my first fuel pump tractor and I thought why not have a primer bulb like two strokes? That's how I found this forum! Such a waste of battery life. I wonder if there is an alternative. Or a kit already out.


  • Senior Member
  • Member No: 62466
  • 901 Thanks
  • 787 posts
  • Location: Minnesota

Posted January 29, 2016 - 07:46 PM

I had a similar problem with my SS16, I installed an electric fuel pump and disabled the pulse pump also work good, the primer bulb is a simpler and less expensive fix.