Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

HT 18 hydraulic lift issues


  • Please log in to reply
5 replies to this topic

#1 1oldbuzz OFFLINE  

1oldbuzz
  • Senior Member
  • Member No: 61298
  • 586 Thanks
  • 465 posts
  • Location: Manitowoc WI

Posted April 17, 2018 - 02:15 AM

Having issues with down pressure

works fine when cold

will lift the front of tractor

issue is no down pressure when warm

where should I start looking

 

 



#2 BOLENSBOY60 OFFLINE  

BOLENSBOY60
  • Member
  • Member No: 33108
  • 86 Thanks
  • 63 posts
  • Location: wisc

Posted April 17, 2018 - 07:21 AM

does it have the eaton 12 or the sunstrand 15?


  • logmillingman said thank you

#3 29 Chev ONLINE  

29 Chev

    A Little Off Plumb

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 63590
  • 9,983 Thanks
  • 3,233 posts
  • Location: Ontario Canada

Posted April 17, 2018 - 09:15 AM

The attached pdf may be of assistance as it contains information that shows what hydro was used in the large frame models, testing and troubleshooting procedures for both hydros - it is a combination of some of the pages from the Large Frame Service Manual and The Eaton 11 repair manual and has bookmarks for easy navigation.  You can print off the pages that contain the information you need rather than the complete document.

 

The symptoms you describe could be caused by various problems, low pressure, bad seals, wrong fluid etc. so I would suggest you verify which hydro you have as suggested by Bolensboy60 (since someone may have changed things since the tractor left the factory) and then start by checking pressures as described in the troubleshooting information.   Looks like originally your tractor should have the Sundstrand hydro according to the first page - hope this helps. 


  • Bud W, logmillingman and Paulgo have said thanks

#4 1oldbuzz OFFLINE  

1oldbuzz
  • Senior Member
  • Member No: 61298
  • 586 Thanks
  • 465 posts
  • Location: Manitowoc WI

Posted April 18, 2018 - 01:34 AM

It has the Sunstrand 15

I think I discovered the problem (yesterday)

when inspecting the tractor

 

there is very lite leakage on the spool

on the up/down piston

 

If this white stuff ever ends

will pull the spool and rebuild


  • logmillingman said thank you

#5 BOLENSBOY60 OFFLINE  

BOLENSBOY60
  • Member
  • Member No: 33108
  • 86 Thanks
  • 63 posts
  • Location: wisc

Posted April 18, 2018 - 06:43 AM

just a thought- I would check your charge pump pressure maybe before removing the control valve- don`t know if a minor leak would nessasarily be the cause- I had a problem with my power sterring not operating rebuilt ps unit- removed -rebuilt control valve- turned out it was my gearotor in the charge pump- the face had very minor sratches- knoe what you meen on the snow- got 20 inches here in central wi from Friday thru sunday

Attached Thumbnails

  • SDC14017.JPG

  • logmillingman said thank you

#6 1oldbuzz OFFLINE  

1oldbuzz
  • Senior Member
  • Member No: 61298
  • 586 Thanks
  • 465 posts
  • Location: Manitowoc WI

Posted April 18, 2018 - 07:18 AM

I don't think its the pump

I am able to lift 300+ pounds

 

if it were the pump I don't think I would be able lift that

 

also O rings in the spool is a cheaper and easier starting point


  • logmillingman said thank you




Top