Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

New carb installed and engine surges


  • Please log in to reply
3 replies to this topic

#1 BrokenTractor OFFLINE  

BrokenTractor
  • Member
  • Member No: 69513
  • 16 Thanks
  • 73 posts
  • Location: CT

Posted November 09, 2017 - 04:10 PM

Hello,

 

I just installed a new Nikki carb on a B&S 14.5 HP and it runs almost OK. I see white smoke coming out of the carb ( where the

choke flap is ).

 

I noticed when I choke it ( after it has been running a few minutes ) say 70% choke, the engine runs flawlessly. From there if I let the choke just sit open ( resting state ) then back to revving and white smoke.

 

I might be able to run it 70% choked, but I am sure this is not the answer, does anyone have any ideas?

 

Thanks,

BT


Edited by BrokenTractor, November 09, 2017 - 04:10 PM.


#2 boyscout862 OFFLINE  

boyscout862
  • Senior Member
  • Contributor
  • Member No: 8923
  • 12,022 Thanks
  • 8,796 posts
  • Location: N.E. Connecticut

Posted November 09, 2017 - 04:31 PM

It sounds like a lean running condition. You may have a vacuum leak or an obstructed fuel passage in the carb. I'd look for the leak. it is often at the mounting gasket from the carb to the engine. Good Luck, Rick

Edited by boyscout862, November 09, 2017 - 04:31 PM.

  • BrokenTractor said thank you

#3 BrokenTractor OFFLINE  

BrokenTractor
  • Member
  • Member No: 69513
  • 16 Thanks
  • 73 posts
  • Location: CT

Posted November 09, 2017 - 05:40 PM

Hi Rick,

 

Thanks. I have the intake manifold direct to the engine itself. No gasket in between. Should there be a gasket between the two?

 

I  found this to be the case in a schematic for the parts. Thanks alot.

 

BT

 

Part required:

 

Briggs & Stratton Small Engine Intake Manifold Gasket 

Edited by BrokenTractor, November 10, 2017 - 07:43 AM.

  • boyscout862 said thank you

#4 boyscout862 OFFLINE  

boyscout862
  • Senior Member
  • Contributor
  • Member No: 8923
  • 12,022 Thanks
  • 8,796 posts
  • Location: N.E. Connecticut

Posted November 09, 2017 - 07:28 PM

Hi Rick,
 
Thanks. I have the intake manifold direct to the engine itself. No gasket in between. Should there be a gasket between the two?
 
I  found this to be the case in a schematic for the parts. Thanks alot.
 
BT


You are welcome. That is why we are here, to share knowledge. Good Luck, Rick




Top