Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

Direction trouble


  • Please log in to reply
4 replies to this topic

#1 daytime dave OFFLINE  

daytime dave

    Live long and prosper

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 531
  • 4,705 Thanks
  • 6,487 posts
  • Location: Upstate NY

Posted October 23, 2017 - 06:22 AM

My Elec Trak has sat for about 6 or 7 years without much movement.  The last four years it hasn't moved at all.  I would just charge the batteries every other month.  The batteries finally wouldn't take a charge.  I found three super deep 12v batteries for free.  I installed them and couldn't get any movement.  The indicator showed full charge, but no forward or reverse movement.  I let it sit for a week.  I tried again and got reverse, but no forward.  This past weekend, I took a closer look.  I took apart the forward and reverse switch and it was fine.  All wires were connected and there was no corrosion evident.

 

Can anyone give me a direction to go in?  I am hoping to use the tractor more, but this set back baffles me.  

 



#2 chieffan OFFLINE  

chieffan
  • Senior Member
  • Contributor
  • Member No: 62695
  • 8,998 Thanks
  • 6,167 posts
  • Location: SW Iowa

Posted October 23, 2017 - 07:54 AM

​Your batteries are probably bad.  Will show a full charge (volts) but won't have any power (amps) to do the work.  Put in new batteries and I bet your good to go.  I know, wrong time of year to be buying batteries unless you plan to use it this winter.


  • boyscout862 said thank you

#3 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 35,791 Thanks
  • 44,563 posts
  • Location: Collinsville, Oklahoma

Posted October 23, 2017 - 04:02 PM

Though unrelated, I have direction control issues too. Never know if I'm coming or going!

Hope someone can help you out, as I haven't a clue!



#4 DH1 ONLINE  

DH1

    Electric Tractors

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 62
  • 5,106 Thanks
  • 5,503 posts

Posted October 23, 2017 - 04:54 PM

Does the volt meter, fuel level meter drop when you try to move it?   What does the power use meter do?

Does the pto work? Any loud clicks from the large contactors?

Brake pedal switch, seat switch, key switch, are they OK?

Connections OK?

 

The GE  Home Owners Service Manual is your best source of how to fix or figure out what is wrong.

I'd post a link but I can't do that on this site.  



#5 daytime dave OFFLINE  

daytime dave

    Live long and prosper

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 531
  • 4,705 Thanks
  • 6,487 posts
  • Location: Upstate NY

Posted November 04, 2017 - 05:37 AM

Thank you all.  Doug, I'll look at that manual.

 

I think I have that manual somewhere.

 

In answer to your questions, everything works, PTO, all switchs and I get the loud click from the contactor when in reverse.  It just does nothing when I have it in forward.  No click, nothing.  Batteries are / were fully charged.  They will be coming out this weekend to be maintained at home.  

 

Thanks for the help


  • DH1 said thank you




Top