Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

Porter Cable


  • Please log in to reply
16 replies to this topic

#1 Dayton_King ONLINE  

Dayton_King
  • Senior Member
  • Member No: 68926
  • 837 Thanks
  • 840 posts
  • Location: Atlanta Georgia

Posted August 27, 2017 - 09:13 AM

Have an old porter cable. Bought it for the wheel weights for one of my Executives. Trans is shot and steering wheel got broken in shipping. I have spares of both. Does any one know what the Paint colors are? My restoration project this fall

Attached Thumbnails

  • 20170826_145528.jpg

  • boyscout862, HANKG and Mark 149 J. have said thanks

#2 TomLGT195 OFFLINE  

TomLGT195
  • Senior Member
  • -GTt Supporter-
  • Member No: 29432
  • 3,369 Thanks
  • 2,592 posts
  • Location: Southern New Hampshire

Posted August 27, 2017 - 01:15 PM

HankG just restored one. White and green. Also check with Jableman. He has several restored ones. Good luck and post pics of the restoration please.
  • boyscout862, HANKG and Dayton_King have said thanks

#3 Dayton_King ONLINE  

Dayton_King
  • Senior Member
  • Member No: 68926
  • 837 Thanks
  • 840 posts
  • Location: Atlanta Georgia

Posted August 31, 2017 - 09:10 AM

Starting collecting parts. I need help on the motor. I have no spark. I can fix that. But my pull starter nut, thing came apart. I am good with kohlers not on pull start briggs. Any source on parts?

Attached Thumbnails

  • 20170828_174520.jpg


#4 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 34,706 Thanks
  • 43,747 posts
  • Location: Collinsville, Oklahoma

Posted August 31, 2017 - 04:33 PM

I may have one of those floating around here with all the push mowers! Gotta look! That is a Briggs?



#5 jabelman OFFLINE  

jabelman
  • Senior Member
  • Member No: 38843
  • 1,969 Thanks
  • 1,445 posts
  • Location: nj

Posted August 31, 2017 - 07:01 PM

Chk your pm
  • Dayton_King said thank you

#6 Dayton_King ONLINE  

Dayton_King
  • Senior Member
  • Member No: 68926
  • 837 Thanks
  • 840 posts
  • Location: Atlanta Georgia

Posted September 01, 2017 - 05:52 PM

Sent you an email. You get it ?

#7 Jonas Monnett ONLINE  

Jonas Monnett
  • Member
  • Member No: 56667
  • 115 Thanks
  • 73 posts

Posted September 02, 2017 - 02:58 AM

I Am Going To Get Myself One Next Week That's Needs Put Back To Together


Sent from my iPhone using Tapatalk

#8 Dayton_King ONLINE  

Dayton_King
  • Senior Member
  • Member No: 68926
  • 837 Thanks
  • 840 posts
  • Location: Atlanta Georgia

Posted September 06, 2017 - 07:56 PM

Trans is swapped over for a good one. Steering wheel is replaced with another. New pull starter installed. Cleaned points still no fire. I ordered new points and condenser. If that does not work I will get a new magneto
  • TomLGT195, Jonas Monnett and Mark 149 J. have said thanks

#9 TomLGT195 OFFLINE  

TomLGT195
  • Senior Member
  • -GTt Supporter-
  • Member No: 29432
  • 3,369 Thanks
  • 2,592 posts
  • Location: Southern New Hampshire

Posted September 07, 2017 - 03:20 AM

Pics , we need pics.  :D



#10 Greasy6020 ONLINE  

Greasy6020
  • Senior Member
  • Member No: 78477
  • 1,149 Thanks
  • 1,093 posts
  • Location: supposedly frozen wastelands of ontario

Posted September 07, 2017 - 10:16 PM

What's wrong with the tranny?

Only trouble I've heard of on the porter cable/moto mower/Massey executives trannies are axles that don't like too big of loads.

Previous owner of my 6020 said he had trouble with getting caught in 2 gears at once... I've never had the trouble. His kids used it as a ride on toy for several years though.

#11 Dayton_King ONLINE  

Dayton_King
  • Senior Member
  • Member No: 68926
  • 837 Thanks
  • 840 posts
  • Location: Atlanta Georgia

Posted September 09, 2017 - 03:45 PM

The trans was shot. They Jerry rigged a bolt on the shift and broke the fork. Only 6 bolts hold the trans to the frame and they are not large bolts either.

I got a flywheel from a 8hp briggs and a magnetron coil. Bolt on and off it went. I need to rebuild the carb. I could have mowed with it today if I had the belt length from the engine to deck.

Attached Thumbnails

  • 20170909_123836.jpg
  • 20170909_123852.jpg

  • Alc, TomLGT195 and MGP59DB have said thanks

#12 MGP59DB ONLINE  

MGP59DB
  • Senior Member
  • Member No: 66960
  • 1,435 Thanks
  • 695 posts
  • Location: West Coast- Mich.

Posted September 09, 2017 - 07:54 PM

That is cool looking ! Glad to see someone knows something about these . I saw one today at a show and well... I had to buy it- the price seemed right.

P1120389.JPG

 


  • Dayton_King said thank you

#13 Dayton_King ONLINE  

Dayton_King
  • Senior Member
  • Member No: 68926
  • 837 Thanks
  • 840 posts
  • Location: Atlanta Georgia

Posted September 09, 2017 - 07:59 PM

I think I have a spare tunnel for it
  • MGP59DB said thank you

#14 jabelman OFFLINE  

jabelman
  • Senior Member
  • Member No: 38843
  • 1,969 Thanks
  • 1,445 posts
  • Location: nj

Posted September 09, 2017 - 08:17 PM

That is cool looking ! Glad to see someone knows something about these . I saw one today at a show and well... I had to buy it- the price seemed right.
P1120389.JPG


I assume you bought the one in the photo? there is a whole website/page about the resto of that particular tractor on the interweb
  • MGP59DB said thank you

#15 MGP59DB ONLINE  

MGP59DB
  • Senior Member
  • Member No: 66960
  • 1,435 Thanks
  • 695 posts
  • Location: West Coast- Mich.

Posted September 10, 2017 - 06:38 PM

I assume you bought the one in the photo? there is a whole website/page about the resto of that particular tractor on the interweb

I did , and no I didn't know about the resto of this . Do you know where?

 

I think I have a spare tunnel for it 

 

If you do have a spare tunnel , I would surely be interested . 

Looking it over today , I found the carb linkage to be fouled up and it fires but wont run , probably due to the fuel line being routed wrong . Its nothing I can't figure out. 






Top