Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

Another Briggs L Head another linkage issue


  • Please log in to reply
5 replies to this topic

#1 bbuckler ONLINE  

bbuckler
  • Senior Member
  • Member No: 59269
  • 2,957 Thanks
  • 2,652 posts
  • Location: Killeen,Tx

Posted June 18, 2017 - 08:36 PM

This time it the 8hp the new linkage is rubbing the carb body. 



#2 stiemmy OFFLINE  

stiemmy
  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 53712
  • 2,526 Thanks
  • 1,825 posts
  • Location: Freekin cold central WI

Posted June 18, 2017 - 09:04 PM

Omg, this time I felt drunk watching the Briggs video!!!

My guess,,,,is the linkage is either installed backwards (whitch can happen), or, the rods are bent up some??

Hard to focus on this one!!!!

Edited by stiemmy, June 18, 2017 - 09:51 PM.

  • bbuckler said thank you

#3 karel OFFLINE  

karel
  • Senior Member
  • Member No: 38218
  • 1,853 Thanks
  • 1,234 posts

Posted June 19, 2017 - 04:59 AM

At frame 0:05 you can plainly see the linkage is on wrong.


Edited by karel, June 19, 2017 - 05:00 AM.

  • bbuckler said thank you

#4 glgrumpy OFFLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 8,270 Thanks
  • 7,657 posts
  • Location: Huntington, IN 46750 North East in State

Posted June 19, 2017 - 07:40 AM

Need much better light and don't wiggle around so much! Sure seems something not right, maybe the lower arm on engine is on wrong or bent? Hard to see much in this video and we don't have the page picture from manual to see correct set-up.


  • bbuckler said thank you

#5 bbuckler ONLINE  

bbuckler
  • Senior Member
  • Member No: 59269
  • 2,957 Thanks
  • 2,652 posts
  • Location: Killeen,Tx

Posted June 19, 2017 - 08:53 AM

I got it fixed I had it put on wrong on the governor arm 



#6 bbuckler ONLINE  

bbuckler
  • Senior Member
  • Member No: 59269
  • 2,957 Thanks
  • 2,652 posts
  • Location: Killeen,Tx

Posted June 20, 2017 - 08:50 AM

Got the linkage fixed and reset the governor but I don't think the governor is working. The throttle will not close and is running full speed. 






Top