Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

Attachment lifting lever will not move up or down on my H14


  • Please log in to reply
10 replies to this topic

#1 logmillingman OFFLINE  

logmillingman
  • Senior Member
  • Member No: 68213
  • 387 Thanks
  • 228 posts

Posted January 11, 2017 - 05:52 PM

Hey guys,

 

need some help, I have been plowing snow with my H14 and now the attachment lifting lever will not move up or down its stuck do you have a remedy for this?

 

Thanks  Stephen



#2 David Brown OFFLINE  

David Brown

    I said I work on them. I never said I fix them!

  • Senior Member
  • Contributor
  • Member No: 8570
  • 4,510 Thanks
  • 2,424 posts

Posted January 11, 2017 - 06:00 PM

It seems strange that it would just freeze up on you.  Check over it to make sure that something isn't interfering with the travel or whatever.  I don't know what you have so I'm grasping at straws here.  Perhaps whatever mechanism that holds the lever in place seized up and a quick squirt of oil would get you going again.  Is it cold enough where you are to freeze everything that fast?


  • logmillingman said thank you

#3 LPBolens OFFLINE  

LPBolens

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 874
  • 1,329 Thanks
  • 949 posts
  • Location: North Central Illinois

Posted January 11, 2017 - 06:26 PM

I would suspect moisture froze in there somewhere behind the dash tower. The lift lever controls the hydraulic cylinder, so you already know there is a valve in there. I had that happen once when I was blowing snow with my H14, and it took the judicious application of a heat gun, followed by some WD-40 to get it working again.
  • boyscout862, sodisr, ClassicBolens and 1 other said thanks

#4 sodisr OFFLINE  

sodisr
  • Senior Member
  • Member No: 9153
  • 663 Thanks
  • 773 posts
  • Location: kenosha Wi

Posted January 12, 2017 - 10:37 AM

I agree with the others,,,   If it worked before and just stopped working,,  I suspect water freezing on the slide behind and below the steering tower.. It's not easy to get at,, but you can see some of it from the side. Kinda between the tube and the cover plate.  get it warmed up and lots of spray lube,, it should free it's self            Good luck    :D


  • logmillingman said thank you

#5 logmillingman OFFLINE  

logmillingman
  • Senior Member
  • Member No: 68213
  • 387 Thanks
  • 228 posts

Posted January 12, 2017 - 09:36 PM

Thanks guys, good advise I will work on it tomorrow it finally warmed up here above freezing



#6 Sawdust ONLINE  

Sawdust
  • Senior Member
  • Member No: 36549
  • 5,462 Thanks
  • 3,296 posts
  • Location: Butler, Kentucky

Posted January 12, 2017 - 11:07 PM

Having an H16 & knowing what's in there it wouldn't take much moisture in there to freeze that area up.
  • logmillingman said thank you

#7 sodisr OFFLINE  

sodisr
  • Senior Member
  • Member No: 9153
  • 663 Thanks
  • 773 posts
  • Location: kenosha Wi

Posted January 23, 2017 - 12:06 PM

Hey guys,

 

need some help, I have been plowing snow with my H14 and now the attachment lifting lever will not move up or down its stuck do you have a remedy for this?

 

Thanks  Stephen

 

 

   WELL  ????   Did you get the problem fixed ????

 

  It's always nice to here of a problem and then ,,what you did to fix the problem....................


  • logmillingman said thank you

#8 logmillingman OFFLINE  

logmillingman
  • Senior Member
  • Member No: 68213
  • 387 Thanks
  • 228 posts

Posted January 23, 2017 - 09:03 PM

I still have not been able to free up the lifting lever, I need to get it in the garage with the heat on and let it sit in there for a couple of days. I will keep you informed it will be a week or so because I have my Husqvarna in the garage installing  a berco snow blower on the front of it.

 

Thanks  Stephen


  • LPBolens and Sawdust have said thanks

#9 Husky OFFLINE  

Husky

    Member

  • Senior Member
  • Contributor
  • Member No: 63
  • 1,238 Thanks
  • 1,098 posts

Posted January 24, 2017 - 12:04 PM

I'll be interested to hear what you find out.


  • logmillingman said thank you

#10 logmillingman OFFLINE  

logmillingman
  • Senior Member
  • Member No: 68213
  • 387 Thanks
  • 228 posts

Posted February 17, 2017 - 10:50 PM

Hey guys finally Got the H14 into the garage last week and let it sit for a few days in the heat. I removed the battery and was able to see down to where the lifting lever goes through the nylon pivot. It was all fused and rusted in place, I found I had a problem with my battery, it shifted and was damaged by the engine pulley, battery acid had flung all around the battery compartment and had gotten into the lifting lever pivot corroding the bracket fusing the nylon bushing so it could not move. I used a pump sprayer with warm water and baking soda and washed everything down a few times until all the acid was neutralized. The baking soda wash freed up the nylon pivot  I then applied some PB Blaster and was finally able to work it so it was loose and working properly. Now every time I take it out to plow I spray the nylon pivot and all the other plow connections with WD 40 to make sure that what ever water that gets into the different areas is displaced by the WD 40 and everything stays nice and free moving.

 

I will be doing another new post to show the new battery bracket that I fabricated to hold the battery in place and the nylon pivot.

 

Stephen


  • sodisr, Sawdust and ClassicBolens have said thanks

#11 Sawdust ONLINE  

Sawdust
  • Senior Member
  • Member No: 36549
  • 5,462 Thanks
  • 3,296 posts
  • Location: Butler, Kentucky

Posted February 18, 2017 - 09:55 AM

That wasn't good but glad you got it cleaned up & working.
  • logmillingman said thank you




Top