Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Craftsman slows down under load

craftsman kohler carburator

  • Please log in to reply
6 replies to this topic

#1 fanboy0199 OFFLINE  

fanboy0199
  • Member
  • Member No: 84806
  • 0 Thanks
  • 3 posts
  • Location: pennsylvania

Posted September 29, 2016 - 07:41 PM

I Have a Craftsman 917.273022 from 1999. it looks like the GT5000. It has a Kohler CV20s... i had to replace the carburetor because the old one caused the motor to surge and not idle... It idles now but when i mow (i have a big hill) it runs at full speed going down but it slows down going up to the point where i have to turn off the mower.... the throttle and carburetor seems to be intact and it never did this till replacing the carburetor. I need some help troubleshooting this..

 

any help would be appreciated 

 

Thanks



#2 Gtractor ONLINE  

Gtractor

    The Tractor Hoarder

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 782
  • 6,625 Thanks
  • 3,917 posts
  • Location: Chillicothe, MO

Posted September 29, 2016 - 08:49 PM

:welcometogttalk:

 

Sounds like your governor, or governor linkage is not set up correctly.  You'll need to reference the manual to double check the connections.  We have lots of manuals on this site - maybe one that will show you what you need. 

:wave:


  • tractorgarden and fanboy0199 have said thanks

#3 Tecumseh power ONLINE  

Tecumseh power

    Jack of all trades, master of none.

  • Senior Member
  • Member No: 77571
  • 943 Thanks
  • 768 posts
  • Location: Vintondale pa

Posted September 29, 2016 - 09:44 PM

Is it hydro?

#4 fanboy0199 OFFLINE  

fanboy0199
  • Member
  • Member No: 84806
  • 0 Thanks
  • 3 posts
  • Location: pennsylvania

Posted September 30, 2016 - 08:37 AM

Yep

#5 MH81 ONLINE  

MH81

    Proud to be Deplorable

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 802
  • 27,311 Thanks
  • 28,632 posts
  • Location: N. W. PA

Posted September 30, 2016 - 11:20 AM

Slows down or bogs down?

#6 crittersf1 OFFLINE  

crittersf1

    GT Lunatic

  • Senior Member
  • Member No: 26142
  • 4,169 Thanks
  • 5,761 posts
  • Location: Newport, N.C.

Posted September 30, 2016 - 11:26 AM

:welcometogttalk: Same question as MH81



#7 fanboy0199 OFFLINE  

fanboy0199
  • Member
  • Member No: 84806
  • 0 Thanks
  • 3 posts
  • Location: pennsylvania

Posted September 30, 2016 - 10:18 PM

It bogs down under load... Like I stated before its runs strong going down hill but bogs down going up... It also seems like it's over revving when I engaged the PTO but then goes back to normal...
Also starts and runs fast then idles within seconds without moving the throttle.




Top