Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

New acquisition


  • Please log in to reply
18 replies to this topic

#16 mjodrey OFFLINE  

mjodrey

    Accumulator

  • Senior Member
  • Contributor
  • Member No: 92
  • 2,343 Thanks
  • 13,481 posts
  • Location: Upper Granville, Nova Scotia, Canada

Posted April 13, 2010 - 12:07 PM

Well I took a little time last night and pulled my glow plugs and checked them.Two aren't working,but someone has changed some before and they are mismatched . They were all autolite but from what I have read,they are about the worst ones I could have,so I've ordered a set of Bosch glow plugs.I hope that is all that was wrong.

#17 NUTNDUN OFFLINE  

NUTNDUN

    Lost in Cyber Space

  • Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 3
  • 10,266 Thanks
  • 15,618 posts
  • Location: Pennsylvania

Posted April 13, 2010 - 12:34 PM

Well I took a little time last night and pulled my glow plugs and checked them.Two aren't working,but someone has changed some before and they are mismatched . They were all autolite but from what I have read,they are about the worst ones I could have,so I've ordered a set of Bosch glow plugs.I hope that is all that was wrong.


I hope the glow plugs fix it for you but I have a feeling that it is loosing prime on the fuel line causing the long start and not so much the glow plugs. I have been wrong before LOL

#18 mjodrey OFFLINE  

mjodrey

    Accumulator

  • Senior Member
  • Contributor
  • Member No: 92
  • 2,343 Thanks
  • 13,481 posts
  • Location: Upper Granville, Nova Scotia, Canada

Posted April 13, 2010 - 02:35 PM

I hope the glow plugs fix it for you but I have a feeling that it is loosing prime on the fuel line causing the long start and not so much the glow plugs. I have been wrong before LOL


No, I have a feeling that your right to some extent ,it does act like it is loosing it's prime,but we'll see.

#19 mjodrey OFFLINE  

mjodrey

    Accumulator

  • Senior Member
  • Contributor
  • Member No: 92
  • 2,343 Thanks
  • 13,481 posts
  • Location: Upper Granville, Nova Scotia, Canada

Posted April 15, 2010 - 10:17 AM

I got the new glow plugs in last night,and to my surprise, it seems to have fixed the problem entirely.Maybe my luck isn't always bad.(knock on wood)




Top