Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Blades won't engage on my L120


  • Please log in to reply
3 replies to this topic

#1 btcompute OFFLINE  

btcompute
  • Member
  • Member No: 83063
  • 1 Thanks
  • 2 posts

Posted May 21, 2016 - 01:13 PM

Hi,

 

While mowing my lawn today, I engaged the blades while I drove the tractor to the next area to mow.

When I got to that spot, I pulled the button to engage the blades, and they did not engage. 

 

Tried a couple times.

Shut of the mower, started it again. Still won't engage.

The belts don't appear to be broken.

 

When I lift the button to engage the blades, I think I hear a 1-2 second change in the sound of the mower, as if it is trying to get the blades moving.

 

Any helpful suggestions would be greatly appreciated.

 

Thanks,

 

Brian

 



#2 lyall ONLINE  

lyall

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 2180
  • 1,746 Thanks
  • 1,398 posts
  • Location: State Center, Iowa

Posted May 21, 2016 - 07:55 PM

check the switch first.  than the wiring.

if that is okay than the your electric PTO might be the problem.

oh - check the belt, too.

 

Welcome to GTTalk


Edited by lyall, May 21, 2016 - 07:56 PM.

  • btcompute said thank you

#3 JD318420 ONLINE  

JD318420
  • Member
  • Member No: 79598
  • 34 Thanks
  • 63 posts
  • Location: Mid-Michigan

Posted May 21, 2016 - 11:35 PM

Also check seat safety switch too, check fuse for the PTO, PTO switch for 12VDC when turn on, wiring for PTO, ground for the PTO, Finally PTO air gap.


Edited by JD318420, May 21, 2016 - 11:37 PM.

  • btcompute said thank you

#4 btcompute OFFLINE  

btcompute
  • Member
  • Member No: 83063
  • 1 Thanks
  • 2 posts

Posted May 24, 2016 - 09:27 AM

Thank you lyall and Russ.

 

It turns out that the tension spring for the mower belt broke.

I got a replacement at the local JD dealer and it works fine now.

 

Brian


  • lyall said thank you




Top