Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Pump problems


  • Please log in to reply
5 replies to this topic

#1 tractor buddy OFFLINE  

tractor buddy

    Member

  • Member
  • Member No: 2928
  • 3 Thanks
  • 56 posts
  • Location: Hanover Mass

Posted May 10, 2011 - 09:32 AM

I have a non factory FEL york john...something. When I hit the lever the lift shutters and stops. The belt stops spining and the pump stops. I am looking for a new link belt (any one have info) do I need a new pump also ?

Attached Thumbnails

  • DSCN4074.jpg
  • DSCN4073.jpg
  • DSCN4072.jpg


#2 ducky OFFLINE  

ducky

    Senior Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 564
  • 1,632 Thanks
  • 3,870 posts
  • Location: Freedom, WI

Posted May 10, 2011 - 10:03 AM

I have seen those belts at Tractor Supply.
I keep one around just to size belts.
Pump should be OK.
Look at the pulleys and make sure they are not wore so the belt can not get traction.
  • tractor buddy said thank you

#3 NUTNDUN OFFLINE  

NUTNDUN

    Lost in Cyber Space

  • Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 3
  • 10,266 Thanks
  • 15,618 posts
  • Location: Pennsylvania

Posted May 10, 2011 - 10:32 AM

I am not real good with hydraulics but possibly a relief valve isn't working correctly?

#4 tractor buddy OFFLINE  

tractor buddy

    Member

  • Member
  • Member No: 2928
  • 3 Thanks
  • 56 posts
  • Location: Hanover Mass

Posted May 10, 2011 - 11:28 AM

would anyone know if the pulley between the engine and trans on a 69 PK (still not sure of model #) is 5/8 "

Edited by tractor buddy, May 10, 2011 - 12:27 PM.


#5 Alc ONLINE  

Alc

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 1094
  • 5,459 Thanks
  • 6,629 posts
  • Location: Bangor Pa

Posted May 10, 2011 - 08:25 PM

Pretty sure they are 1/2" wide

#6 ducky OFFLINE  

ducky

    Senior Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 564
  • 1,632 Thanks
  • 3,870 posts
  • Location: Freedom, WI

Posted May 10, 2011 - 08:33 PM

I am pretty sure we are looking at a slip issue.
Belt wore/Pulley wear?
If pump was an issue you should see belts smoking and a heavy load on the engine.
With out a heavy load on the engine and pump stops turning you for sure have a drive problem. (Belt/Pulley)




Top