Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

Used Power washer today

  • Please log in to reply
1 reply to this topic

#1 glgrumpy OFFLINE  


    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,477 Thanks
  • 6,358 posts
  • Location: Huntington, IN 46750 North East in State

Posted May 07, 2016 - 09:23 PM

May remember I bought Craftsman Power washer, like new and when I ran it, was goofy and oil came out all over and rough running?  I can't find the orig post or where it was at, so updating here. I drained the oil awhile back, seemed too full. Some thought of gas getting into it from leaky float or other item.  I tore down some today to look at carb. I see the gas line had NO shut-off on it. I went got one, even tho very short hose, got it in there and easy to reach. Put in the new oil. I ran it and it started, not really smoking. Ran a little rough once it warmed some. I see the choke was closing, sort of when governor kicks in. What????   This thing has plastic everywhere on controls to carb and even the float AND needle were plastic.  I finally figured out that with maybe someone tinkering with it or such, the choke lever link was on the wrong side of the gov link. Once I flipped that over to other side and it didn't pull no more, it ran right, woopee!  I pulled the float to see about setting diff, but there is NO way that I can see to adjust. Was a plastic float with a little finger grip on both sides of the plastic needle end and nothing to bend or hold better. Seemed to be holding fine, so put back together. I did not have the Smoking and oil running out problem again. I did run out of gas when trying it. Darn thing shuts right off, no slow down or nothing, just like a switch w/out gas.  I hooked up again later today and blew off some parts. There is one tip missing on the handle holder and think I need to get that. My Ace has those.  One tip was just kind of a wash app, no power really, one was the strong straight and the one I used most showed 25 degrees or something like that, a wider spray. The missing one shows 15 degrees on the holder.  It worked well. There is no throttle control on the thing and when you just hit OFF switch it will quit, but with a BANG!  So, now I reach under cleaner and push the throttle back lower and then off switch, much better. I have no idea what oil issue was, but seems to be not there now. Starts easy, does fine. I like it.  I do shut off gas right away when stopped, maybe that is gonna be the answer to the problem for now at least.

  • MH81 and boyscout862 have said thanks

#2 JDBrian OFFLINE  


    Super Moderator

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2507
  • 9,574 Thanks
  • 14,136 posts
  • Location: Hubley, Nova Scotia - Canada

Posted May 08, 2016 - 05:49 AM

Sounds good. That washer should help clean up your dirty PK