Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Walbro Carb on a Tech 16 Runs Over


  • Please log in to reply
19 replies to this topic

#16 sodisr OFFLINE  

sodisr
  • Senior Member
  • Member No: 9153
  • 651 Thanks
  • 762 posts
  • Location: kenosha Wi

Posted March 10, 2016 - 01:19 PM

Mine leaks out the air-inlet once in a while..  Like I flooded it,, but did not use the choke..  If I tap on the carb with the back of a screw driver,, and I turn off the throttle, and my batt. holds up, it usually starts after a bit...  I'm thinking my float.,, or needle.   But when running it will run fine for a long while ..

  

 It usually happens when I shut it off for a few minutes and then try to restart it..   Good luck and I'll be watching this one... 



#17 wurzel OFFLINE  

wurzel
  • Senior Member
  • Member No: 78672
  • 113 Thanks
  • 101 posts
  • Location: Worcestersire UK

Posted March 10, 2016 - 01:41 PM

Mine leaks out the air-inlet once in a while..  Like I flooded it,, but did not use the choke..  If I tap on the carb with the back of a screw driver,, and I turn off the throttle, and my batt. holds up, it usually starts after a bit...  I'm thinking my float.,, or needle.   But when running it will run fine for a long while ..

  

 It usually happens when I shut it off for a few minutes and then try to restart it..   Good luck and I'll be watching this one... 

hole in the float test with boiling water 


  • sodisr said thank you

#18 wurzel OFFLINE  

wurzel
  • Senior Member
  • Member No: 78672
  • 113 Thanks
  • 101 posts
  • Location: Worcestersire UK

Posted March 20, 2016 - 05:24 PM

Carb was rebuilt last fall.  In a G16XT.  Has worked good all winter.  I always turn the gas off on all my tractors when not used.  This spring I drove it out of the machine shed and it flooded out and fuel was running out the carb like there was no tomorrow.  Have used it a couple times since and it runs good, but have to adjust the fuel flow with the shut off valve.  Today I got it to the shop, removed the carb and the float bowl.  Everything was clean but blew it out just the same.  Tried it several times but it always wants to run gas out the air intake.  With the bowl off I just barely move the float up and it stops the fuel flow.  I have adjusted the float to a lower setting and no change.  I tired 2 different needles the same type and length only with the rubber tip.  No change.  The float is not leaking or hanging up on anything.  The engine runs great as long as I just crack the shut off valve to keep it from running over.  What the heck is going on?  Have never run into this type situation before.  Usually it is dirt or worn needle valve, etc.  Any advise is welcome.  Carb kit probably don't have more than 5 hours run time on it.  Rest of the time the fuel is turned off.

is this fixed now 



#19 chieffan ONLINE  

chieffan
  • Senior Member
  • Contributor
  • Member No: 62695
  • 6,147 Thanks
  • 4,494 posts
  • Location: SW Iowa

Posted March 23, 2016 - 05:04 AM

Didn't make any post earlier as I was not sure which way this was going to end up.  Removed the float again and did the hot water test.  Found a pin hole plus there was gas in the float again.  Drilled a tiny hole in the float to get the gas all out and soldered it shut.  Checked out good so put it back together.  Used the tractor for some yard work for an hour or so.  Everything went fine.  Stopped for lunch and left the gas on.  Set for about an hour and all OK.  Fired it up and started for the lower building and didn't get 20 feet before it was flooding out,  Had to regulate the gas with the shut off again.  Parked it on the level and turned the key off and shortly gas was running out the intake.  Shut the gas off and have a new float coming from Brian when he get it in.  Don't remember where I got the carb kit from but most all it get from Brian, unless it happens to be one I need right now.  Will see what happens when the float gets here.  Till then it is parked.


  • Alc and KennyP have said thanks

#20 wurzel OFFLINE  

wurzel
  • Senior Member
  • Member No: 78672
  • 113 Thanks
  • 101 posts
  • Location: Worcestersire UK

Posted March 23, 2016 - 06:19 AM

maybe another pinhole in float 






Top