Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

Cub 582 started earlier, but won't now

  • Please log in to reply
1 reply to this topic

#1 daytime dave OFFLINE  

daytime dave

    Live long and prosper

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 531
  • 4,441 Thanks
  • 6,332 posts
  • Location: Upstate NY

Posted April 27, 2011 - 05:45 PM

I was at dad's today, to get his back up generator going as his newer emergency generator was down for repairs. It started right away, so that was easy. He said while I was there, the 582 could use an oil change.

It sat all winter with a trickle charger on the battery. A turn of the key and it only ticked away. I got my jump pack and it fired right up. Drove it around, changed the oil. The starter switch was getting bad, as the key just would go around and then not go back in. A few more starts with the jump pack and the starter switch was a goner.

I called Napa and they said they had a couple. I'm not too mechanically inclined, so I brought the old one. The fellow said either starter in stock would work, they were both five prong. Installed it and nothing. Not even a ticking. Went back and got a new solenoid and installed that. Nothing. Not even ticking with the jump pack. The voltage gauge moved slightly each time I tried the switch. I checked all connections, I wire brushed the connections I could. I tried another battery that had also charged all winter. Same thing, nothing. Ground was cleaned and checked. Dad and I are now wondering if anyone can offer any suggestions.


Edited by daytime dave, April 27, 2011 - 05:51 PM.

#2 mikebramel OFFLINE  


    Ron Paul

  • Senior Member
  • Member No: 82
  • 176 Thanks
  • 1,009 posts
  • Location: Milwaukee

Posted April 27, 2011 - 06:16 PM

Take your multimeter, and make sure you have good continuity
Switch body to negative cable
12v at the switch