Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

help needed


  • Please log in to reply
2 replies to this topic

#1 metalmopar OFFLINE  

metalmopar
  • Member
  • Member No: 80207
  • 3 Thanks
  • 3 posts
  • Location: Dallas or

Posted January 28, 2016 - 05:18 PM

i have a Montgomery wards model 33148a lawn tractor that i am currently working on. the issue i am running into it that it seems it doesn't want to go into drive and i think there maybe a problem with the hydro-static drive i dont know if the fluid is low or if there is some sort of filter that could be clogged  because it moves under its own power a little bit but gives up after a minute or 2.any ideas?


  • 637Yeoman said thank you

#2 Genem OFFLINE  

Genem
  • Member
  • Member No: 52933
  • 65 Thanks
  • 47 posts
  • Location: nminn

Posted January 28, 2016 - 06:05 PM

You have a Gilson made 1972 Montgomery wards 15hp .The oil filter is a {PH45 fram} if you want to replace it. Raise the right rear wheel 4' and remove the pipe plug right behind the filter.The oil should be at the level of the removed plug. Type A trans fluid is what was used from factory { it is a slow process if you have to fill it}. Make sure that the tow bar is all the way down, that would cause the tractor not to work. Gene
  • Gtractor, TomLGT195 and 637Yeoman have said thanks

#3 glgrumpy OFFLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,664 Thanks
  • 6,480 posts
  • Location: Huntington, IN 46750 North East in State

Posted January 28, 2016 - 07:25 PM

Raise 4'?  Maybe 4"?   Would be laying on it's side otherwise. :D   I believe it is fluid level myself also. Not sure you can get type A anymore, but isn't Dexron 3 the newest version then? 


  • 637Yeoman said thank you




Top