Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

Any into electronics?

  • Please log in to reply
18 replies to this topic

#16 MH81 ONLINE  


    God Bless Those Who Served

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 802
  • 26,669 Thanks
  • 28,318 posts
  • Location: N. W. PA

Posted December 30, 2015 - 06:39 PM

Sounds like the motor bushings are worn enough to allow it to short.
Grab each end and see if there is much play.
What are the values on the caps BTW?

#17 glgrumpy OFFLINE  


    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,492 Thanks
  • 6,369 posts
  • Location: Huntington, IN 46750 North East in State

Posted December 30, 2015 - 10:54 PM

I don't know oil-less, but was told they don't last as long and are very noisy!  Seems that is all they are offering tho in less expensive units now days. Maybe you just Wore it out!  :smilewink:  Are parts available to rebuild these?  Is it a Sears?  Searsparts.com might have them or offer other help?  My .02 worth! :(


  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 24522
  • 6,415 Thanks
  • 4,880 posts
  • Location: "Hamiltucky" Ohio

Posted December 31, 2015 - 05:11 PM

I think I fixed it. After trying to use die grinder with my 6 gal, I had to try to figure out what is wrong. It worked the first time after I thought I fixed it so when it started kicking breaker again, confusing. I removed the plastic housing holding the capacitors and inspected, looked fine. When I put the 2 screws back in, the bottom one got tight, but plastic bracket was sloppy. I tighten screw some more and it kept going and plastic then got tight. Plugged in and fired right up. I think the first time I didn't get tight and it started but then plastic bracket slid off end and that was problem. I started /stooped several times and seemed to be okay. I wonder how many of these were pitched cause off a broken plastic bracket?

GL, it's a porter cable. I bought it through Lowes many years ago, 2003, 2004? 

#19 toomanytoys84 OFFLINE  



  • Senior Member
  • Member No: 45129
  • 8,047 Thanks
  • 4,977 posts
  • Location: Ohio

Posted December 31, 2015 - 05:39 PM

In late on this one..but I have an old old Rockwell table saw that was giving me fits. I'd turn it on and it would knock my breaker. Reset breaker. Same result. Figured motoe was shorted. Dad started messing with it and spin the motor with his hand and awhile it was rolling turned it on and she ran perfect. Changed the start cap on the motor and now it works 100%
  • TAHOE said thank you