Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Ohh boy... This is getting serious


  • Please log in to reply
18 replies to this topic

#16 daytime dave OFFLINE  

daytime dave

    Live long and prosper

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 531
  • 4,485 Thanks
  • 6,353 posts
  • Location: Upstate NY

Posted December 07, 2015 - 09:37 AM

That looks like a decent GT for the money.  I hope it pulls all you want it to.



#17 SpeedySqueegee OFFLINE  

SpeedySqueegee
  • Member
  • Member No: 78103
  • 34 Thanks
  • 12 posts
  • Location: Oklahoma

Posted December 07, 2015 - 08:59 PM

Thank MolonLabe for the link to the manual. I found the side drive belt cover on e-bay and will try to get it. Got the tranny flush and refill on the agenda for tomorrow along with engine oil, gas tank cleaning, replace fule lines and clean carb. Then I will try for a start up.

#18 MolonLabe OFFLINE  

MolonLabe

    Rust Wrangler

  • Senior Member
  • Member No: 59683
  • 411 Thanks
  • 215 posts
  • Location: Noblesville, In.

Posted December 07, 2015 - 09:43 PM

Thank MolonLabe for the link to the manual. I found the side drive belt cover on e-bay and will try to get it. Got the tranny flush and refill on the agenda for tomorrow along with engine oil, gas tank cleaning, replace fule lines and clean carb. Then I will try for a start up.

Sounds like you are well on your way to getting the old girl back in service. If you're going to replace the fuel line you might as well pull the shut off valve out of the gas tank and clean the screen, just pull it straight down out of the grommet. When you run the new gas line make sure it stays above the fan gear for the steering otherwise it'll get pinched  between the gear and frame, learned that one the hard way. Lots of help on here if you need it, good luck!



#19 SpeedySqueegee OFFLINE  

SpeedySqueegee
  • Member
  • Member No: 78103
  • 34 Thanks
  • 12 posts
  • Location: Oklahoma

Posted December 12, 2015 - 04:48 PM

Okay I got it running!!! Still needs the drive belt cover. Beside that, I think it is ready to work.

Attached Thumbnails

  • image.jpg

  • MolonLabe and Paulgo have said thanks




Top