Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

14 hp Vanguard running like crap!


  • Please log in to reply
3 replies to this topic

#1 Diesel1050 OFFLINE  

Diesel1050

    Diesel Nut!

  • Senior Member
  • Member No: 69580
  • 343 Thanks
  • 393 posts
  • Location: Minot Maine

Posted September 15, 2015 - 07:18 PM

Have a 14 hp horizontal shaft Vanguard that starts, but doesn't run right whatsoever. It used to start, and run with the choke on, but wouldn't rev up. Then I got it to the point where I would have to choke it every minute or so to keep it running. Now after messing with the idle adjustment screw it starts and runs wide open with the ckoke off, but if I turn the choke on it drops to idle. It only needs to run about 1/3 throttle. What am I doing wrong?

#2 backyardtinker OFFLINE  

backyardtinker
  • Senior Member
  • Member No: 73578
  • 249 Thanks
  • 182 posts
  • Location: massachusetts

Posted September 15, 2015 - 08:23 PM

Sounds like your carb is gummed up. May want to put a carb kit in it and be sure to clean it out really good. Get every passage cleared out completely. I would start there.


  • Chopperhed said thank you

#3 Chopperhed OFFLINE  

Chopperhed
  • Senior Member
  • Member No: 20120
  • 1,852 Thanks
  • 1,071 posts
  • Location: Edmonton, Ab, Canada

Posted September 15, 2015 - 10:48 PM

Sounds like your carb is gummed up. May want to put a carb kit in it and be sure to clean it out really good. Get every passage cleared out completely. I would start there.

Like he said, in my experience, these thing start in the carb 95% of the time


  • backyardtinker said thank you

#4 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted September 18, 2015 - 05:31 PM

Just had MY vanguard racing after a full throttle run and that is all it would do. Had to adjust the governor at the shaft it mounts on. Loosen it and turn shaft all way right or left, forget which I did, and it ran and idled and mid range perfect after that. Maybe a procedure is on line for that? I was guessing it was same as a kohler and seemed to work. The turn range of the shaft is minimal tho, don't expect much movement.


  • Chopperhed said thank you




Top