Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Massey 12 4 spd. problem


  • Please log in to reply
12 replies to this topic

#1 jscam OFFLINE  

jscam

    Member

  • Member
  • Member No: 1902
  • 21 Thanks
  • 69 posts
  • Location: Jenks, Ok.

Posted April 01, 2011 - 06:35 AM

Hey, guys, I'm trying to split my transaxle to replace detent springs and seals. The problem is, after I have removed the snap clip from the end of the axle, I can't get the hub off. It's been soaked with penetrationg fluid, LOTS of pressure with a 3 jaw puller, tapped on, and heated. Still no luck............any suggestions?

#2 IamSherwood OFFLINE  

IamSherwood

    Elf guardian

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 2066
  • 8,379 Thanks
  • 7,696 posts
  • Location: Northern Ontario

Posted April 01, 2011 - 06:57 AM

Bigger puller and more heat.
I had the same, h#$l of a time getting mine apart.
I believe I even had to make my own puller(stronger), and pulled on the hub close to the shaft, so as not to
break the hub.
You're going to replace seals anyways, so heat the hub red hot.

#3 tractorgarden ONLINE  

tractorgarden

    Junk Whisperer

  • Senior Member
  • -GTt Supporter-
  • Member No: 2291
  • 1,277 Thanks
  • 1,432 posts
  • Location: northwest pa

Posted April 01, 2011 - 07:04 AM

:iagree:You can try to apply some candle wax after heating, sometimes peening with a needle scaler after heating helps, the most important thing is take your time, use all the things that you have been using, I have been breaking down those for years and still end up breaking some,good luck, Shawn

#4 jscam OFFLINE  

jscam

    Member

  • Member
  • Member No: 1902
  • 21 Thanks
  • 69 posts
  • Location: Jenks, Ok.

Posted April 04, 2011 - 06:10 AM

Thanks guys...............going for some mapp gas today..............see if I can heat this thing up a little bit...........

#5 NUTNDUN OFFLINE  

NUTNDUN

    Lost in Cyber Space

  • Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 3
  • 10,266 Thanks
  • 15,618 posts
  • Location: Pennsylvania

Posted April 04, 2011 - 07:49 AM

Thanks guys...............going for some mapp gas today..............see if I can heat this thing up a little bit...........


I hope you are able to get the hubs off. I was fortunate, both of mine came off really easy but they also wobble a little bit too. Good luck.

#6 jscam OFFLINE  

jscam

    Member

  • Member
  • Member No: 1902
  • 21 Thanks
  • 69 posts
  • Location: Jenks, Ok.

Posted April 05, 2011 - 04:51 PM

Finally got one off, it took about 3 hrs. of heating, (I upgraded to mapp gas for more heat) adding pressure to the puller, and hammering on the back side of the hub. That darned thing fought me the whole way to the last 1/8 inch. Now, if I can get the other one.............. Nutndun............no wobble in these........for now anyway........LOL

#7 DH1 ONLINE  

DH1

    Electric Tractors

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 62
  • 4,587 Thanks
  • 5,295 posts
  • Location: Markham Ontario Canada

Posted April 05, 2011 - 04:59 PM

Finally got one off, it took about 3 hrs. of heating, (I upgraded to mapp gas for more heat) adding pressure to the puller, and hammering on the back side of the hub. That darned thing fought me the whole way to the last 1/8 inch. Now, if I can get the other one.............. Nutndun............no wobble in these........for now anyway........LOL


Do you really have to take the other one off?
When you slit the case you only need to remove the right side.

#8 jscam OFFLINE  

jscam

    Member

  • Member
  • Member No: 1902
  • 21 Thanks
  • 69 posts
  • Location: Jenks, Ok.

Posted April 05, 2011 - 07:54 PM

DH1, you are correct according to some of the other guys on the site.......and I have thought about that but, while I'm there, I want to change the seals and check the bearing on the other side while it's out. And, the way things work for me..........if I don't do it now while it's out............something WILL fail and I'll be doing it all over again.......and if I did'nt, it would always bug the crap out of me........LOL

#9 NUTNDUN OFFLINE  

NUTNDUN

    Lost in Cyber Space

  • Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 3
  • 10,266 Thanks
  • 15,618 posts
  • Location: Pennsylvania

Posted April 05, 2011 - 07:56 PM

DH1, you are correct according to some of the other guys on the site.......and I have thought about that but, while I'm there, I want to change the seals and check the bearing on the other side while it's out. And, the way things work for me..........if I don't do it now while it's out............something WILL fail and I'll be doing it all over again.......and if I did'nt, it would always bug the crap out of me........LOL


My luck would be that it would have been the left one that I took off first LOL.

#10 jscam OFFLINE  

jscam

    Member

  • Member
  • Member No: 1902
  • 21 Thanks
  • 69 posts
  • Location: Jenks, Ok.

Posted April 11, 2011 - 08:46 PM

Finally got the other side off......wow,......what a fight..........trashed the outside bearings of course with all of the heat ................oh well..............finally I can split that thing.......

#11 NUTNDUN OFFLINE  

NUTNDUN

    Lost in Cyber Space

  • Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 3
  • 10,266 Thanks
  • 15,618 posts
  • Location: Pennsylvania

Posted April 18, 2011 - 10:21 AM

Finally got the other side off......wow,......what a fight..........trashed the outside bearings of course with all of the heat ................oh well..............finally I can split that thing.......


Good job getting the hub off. Let us know how you make out with the tranny then.

#12 jscam OFFLINE  

jscam

    Member

  • Member
  • Member No: 1902
  • 21 Thanks
  • 69 posts
  • Location: Jenks, Ok.

Posted April 18, 2011 - 05:44 PM

nutndun............Im going to follow your instructions to the t........................I'll let you know..............parts are in the soak............finally got my electorlisis rig up and running...................may put the sandblaster on ebay..........LOL

#13 IamSherwood OFFLINE  

IamSherwood

    Elf guardian

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 2066
  • 8,379 Thanks
  • 7,696 posts
  • Location: Northern Ontario

Posted April 19, 2011 - 06:49 AM

Glad you got those hubs off. Sounds like they gave you a run for the money.
Good plan to replace seals and brgs an both sides while your at it.




Top