Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

91 Promaster 300


  • Please log in to reply
3 replies to this topic

#1 Darby OFFLINE  

Darby
  • Member
  • Member No: 71388
  • 0 Thanks
  • 2 posts
  • Location: New York

Posted June 01, 2015 - 08:23 AM

New to the Forum...

 

  Need some help.

 

I have a 1991 Promaster 300, 20 horse MV with Walbro carb.  Engine stutters badly going downhill.  Ok going uphill, and sidehill. Took carb apart, cleaned.....still does it.  Might be unrelated, but does almost the same thing in reverse when deck is down.   Some switch I don't know about?   Thanks for any help.....



#2 boyscout862 ONLINE  

boyscout862
  • Senior Member
  • Member No: 8923
  • 9,753 Thanks
  • 7,523 posts
  • Location: N.E. Connecticut

Posted June 01, 2015 - 09:36 AM

Welcome to GTT. The stutter is probably a lean mixture condition. Check the fuel flow to the carb. The new gas blends are hard on fuel lines, filters, and carbs. Did you clean all the tiny passages in the carb when you had it out. Check our Manuals Section(3 free downloads per day) for your engine manual. I sometimes use a strand of soft copper wire to gently clean carb passages that are too small for a Qtip or a soft torch nozzel brush. Good Luck, Rick



#3 TomLGT195 OFFLINE  

TomLGT195
  • Senior Member
  • -GTt Supporter-
  • Member No: 29432
  • 2,795 Thanks
  • 2,193 posts
  • Location: Southern New Hampshire

Posted June 01, 2015 - 04:14 PM

:welcometogttalk:  :wewantpics:  please. 



#4 Darby OFFLINE  

Darby
  • Member
  • Member No: 71388
  • 0 Thanks
  • 2 posts
  • Location: New York

Posted June 03, 2015 - 11:56 AM

Thank you....will work on the carb again...




Top