Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

New Problem on my 1920 Ultima


  • Please log in to reply
2 replies to this topic

#1 toppop52 OFFLINE  

toppop52
  • Senior Member
  • Member No: 54420
  • 3,450 Thanks
  • 3,359 posts
  • Location: Lower Eastern Shore of Maryland

Posted May 10, 2015 - 08:42 PM

When I'm mowing, the longer I mow, the more this happens. It will suddenly turn off the pto clutch as voltage drops to near zero, then it will start to surge and usually start charging and go back to normal. I also notice that it appears to have weak fuel pump and the flow is weak. Fuel will boil a bit in the filter like a vapor lock condition, but that doesn't explain the voltage drop before the running gets rough. I'm wondering if the pto is somehow shorting or some other short exists. These tractors being similar to Massey, Simplicity, etc... I thought maybe someone had run into this.

#2 UncleWillie OFFLINE  

UncleWillie

    wabbit wangler

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 10399
  • 12,736 Thanks
  • 7,695 posts
  • Location: Gaston county, NC

Posted May 11, 2015 - 10:38 AM

If the fuel is boiling then the motor is not making enough power to run the pto most likely. Pull the tins off the engine and see if there is a rat condo in there.


  • toppop52 said thank you

#3 toppop52 OFFLINE  

toppop52
  • Senior Member
  • Member No: 54420
  • 3,450 Thanks
  • 3,359 posts
  • Location: Lower Eastern Shore of Maryland

Posted May 11, 2015 - 07:33 PM

I guess that could be. I'll look into it.




Top