Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Agway 2125 starting issues, please help

12.5 hp not starting

  • Please log in to reply
10 replies to this topic

#1 superman7928 OFFLINE  

superman7928
  • Member
  • Member No: 69887
  • 0 Thanks
  • 5 posts
  • Location: Pa

Posted April 24, 2015 - 03:30 PM

Hi,

 I could use some help. I have a Agway 2125 12.5 hp tractor. I am having problems starting it. it has a brand new battery but it acts like the battery is dead. When I try to start it either nothing happens or it wil make one revolution but will not turn over. I have started it by hooking my jumper box right to the starter. Any help would be appreciated. Thank you..



#2 HDWildBill ONLINE  

HDWildBill

    Freedom is not Free. Thank those in uniform for your freedom.

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 6354
  • 8,712 Thanks
  • 8,564 posts
  • Location: Ga

Posted April 24, 2015 - 03:40 PM

Welcome Aboard.  Pretty bold user name. :poke:    From your description I would suspect the starter solenoid, but it could be wiring or ignition switch. Have you tried jumping across the solenoid? What is the make of the engine?


  • boyscout862 and superman7928 have said thanks

#3 boyscout862 ONLINE  

boyscout862
  • Senior Member
  • Member No: 8923
  • 9,803 Thanks
  • 7,543 posts
  • Location: N.E. Connecticut

Posted April 24, 2015 - 06:17 PM

Welcome to GTT. You are going to have to do some electrical diagnosis. The first suspect is a bad or intermittent ground. The second is a loose or corroded electrical connection. If checking and cleaning connections doesn't fix it, take some pics and post them with a description of what it is and isn't doing. Good Luck, Rick


  • superman7928 said thank you

#4 superman7928 OFFLINE  

superman7928
  • Member
  • Member No: 69887
  • 0 Thanks
  • 5 posts
  • Location: Pa

Posted April 28, 2015 - 10:47 AM

ok... I have worked on it a little more. I found that if I pulled up on the blades past them being disengaged it started a couple times but a couple times it did the same thing. i could not get it to start at all before pulling up on the blades. it still does not start all the time while holding the blades up, also if i pull the plug out it will turn over like there's nothing wrong, when put back in it acts like it did before. Thanks in advance for the help...



#5 boyscout862 ONLINE  

boyscout862
  • Senior Member
  • Member No: 8923
  • 9,803 Thanks
  • 7,543 posts
  • Location: N.E. Connecticut

Posted April 28, 2015 - 10:58 AM

Sounds like it is a safety switch for the deck. Find it and test it. Good Luvk, Rick



#6 superman7928 OFFLINE  

superman7928
  • Member
  • Member No: 69887
  • 0 Thanks
  • 5 posts
  • Location: Pa

Posted April 28, 2015 - 11:56 AM

Ok. im lost. lol.. I have an interstate 12v battery in it. reads 12.0 on my meter. I hooked up my jumper box right to the battery and it started right up without holding the blades up. took the jumper box off put my meter on it while it was running 12.8v. turned the tractor off would not start meter reads11.0... the starter jumps up and it acts like it wants to turn but wont. I did forget to mention in my earlier post that i had the tractor hooked up via jumper cables to a huskee battery that I just bought when I had it started earlier. Thanks again in advance



#7 superman7928 OFFLINE  

superman7928
  • Member
  • Member No: 69887
  • 0 Thanks
  • 5 posts
  • Location: Pa

Posted April 30, 2015 - 11:50 AM

Any suggestions??? :wallbanging:



#8 VTXrider OFFLINE  

VTXrider
  • Senior Member
  • Member No: 16031
  • 463 Thanks
  • 332 posts
  • Location: West Michigan

Posted May 01, 2015 - 07:06 AM

Can you install the huskee battery in the tractor and try it? Not unheard of to get a bad new battery.

Check all the heavy cable connections. Battery to ground, battery to solenoid and solenoid to starter. Unbolt and clean each.

Try to jump across the solenoid heavy cable terminals. It should turn over but not start unless the key is on.

Try to jump from the battery + post to the starter post. Same thing should happen as above.

Still no starter action, the engine ground to the frame may have corroded. Attach a wire from the engine block to the frame.

 

This is a repeat of what Boyscout posted. The last thing is the starter itself may be worn out. Post back what you find. 


Edited by VTXrider, May 01, 2015 - 07:11 AM.

  • superman7928 said thank you

#9 superman7928 OFFLINE  

superman7928
  • Member
  • Member No: 69887
  • 0 Thanks
  • 5 posts
  • Location: Pa

Posted May 01, 2015 - 11:38 AM

ok. I cant install the huskee battery because it wont fit. I did some research and found that the battery that is in there has lower amp hours then mtd recommends. I tried jumping with the battery and the same thing. the starter jumps up but will not turn over. It will turn over like that with the jumper box. Thanks again for all the help



#10 WNYTractorTinkerer ONLINE  

WNYTractorTinkerer

    Tinker Master

  • Senior Member
  • -GTt Supporter-
  • Member No: 10789
  • 8,318 Thanks
  • 4,665 posts
  • Location: Avon, NY

Posted May 01, 2015 - 01:01 PM

If the engine in that thing is a Briggs & Stratton it may be time for a valve clearance check/adjustment.  The B&S 'compression release' is a little bump on the cam..  If the valve clearance is wrong the C/R will not work correctly and what you are describing is the result of this..  Hard cranking..  Just a thought for ya



#11 VTXrider OFFLINE  

VTXrider
  • Senior Member
  • Member No: 16031
  • 463 Thanks
  • 332 posts
  • Location: West Michigan

Posted May 01, 2015 - 01:40 PM

Have you done the suggested tasks? We start from the easiest fixes first, trying to narrow down the issue, before going out and buying parts.







Also tagged with one or more of these keywords: 12.5 hp, not starting

Top