Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

John Deere 420 charge light


  • Please log in to reply
2 replies to this topic

#1 jwinfrey OFFLINE  

jwinfrey

    Member

  • Member
  • Member No: 2378
  • 2 Thanks
  • 10 posts

Posted March 19, 2011 - 08:15 PM

I cannot get the charge light to go off on my 420 it has a new battery and my regulator is getting 50 volts ac at wot and putting out 12.9 volts dc at wot. is my regulator messed up or any suggestions

#2 ducky OFFLINE  

ducky

    Senior Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 564
  • 1,630 Thanks
  • 3,869 posts
  • Location: Freedom, WI

Posted March 19, 2011 - 09:54 PM

It appears charging system is working to a point. A little low on volts but should maintain the battery.
Put a volt meter across the battery and read the voltage. Then start the tractor and see if the voltage rises as the tractor runs.
I have a 316 with the circuit board in the dash. Hate it just like to do things old school. (Volts and Amps)

#3 Gary400 OFFLINE  

Gary400

    JD,junkie

  • Senior Member
  • Contributor
  • Member No: 2316
  • 225 Thanks
  • 768 posts
  • Location: North East Missouri

Posted March 26, 2011 - 08:06 PM

my 318 charge light used to come on for a short time then go off then back on then off then it stayed on and would not go off . i checked and it was charging but the light was on so i unplugged the wires to the light put a little contact grease on them plugged them back on and the light went out . you may try that could be just the connection on the light it self .




Top