Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

some videos on my machines


  • Please log in to reply
4 replies to this topic

#1 craftsmanmowerfreak OFFLINE  

craftsmanmowerfreak
  • Senior Member
  • Member No: 16215
  • 258 Thanks
  • 222 posts
  • Location: Indiana

Posted March 01, 2015 - 09:03 PM

havent really been posting here much so i thought i share these. here are a few videos of my machines
 
my 73 st10 modified tractor and dads 72 compact 8e plowing his lights blew a fuse half way through 

 
video discussing the st10

 
my junker ss14

 
my ss15 

 
ss15 during repower a few months before paint
https://www.youtube.com/watch?v=G2xtcVVg6_E
 
 
i have more videos planned has i go through the year
  • MH81, Username, Delmar and 8 others have said thanks

#2 MH81 ONLINE  

MH81

    Proud to be Deplorable

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 802
  • 27,300 Thanks
  • 28,626 posts
  • Location: N. W. PA

Posted March 01, 2015 - 10:06 PM

Thanks for the vids, I subscribed, now to watch some GT's
  • craftsmanmowerfreak said thank you

#3 KennyP OFFLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,461 Thanks
  • 39,690 posts
  • Location: Collinsville, Oklahoma

Posted March 02, 2015 - 05:54 AM

Cool videos! Have seen a lot of them this winter!


  • craftsmanmowerfreak said thank you

#4 KC9KAS OFFLINE  

KC9KAS
  • Senior Member
  • Member No: 10038
  • 4,783 Thanks
  • 4,303 posts
  • Location: Holland, IN

Posted March 02, 2015 - 05:48 PM

:welcometogttalk:

And thanks for the videos!


  • craftsmanmowerfreak said thank you

#5 craftsmanmowerfreak OFFLINE  

craftsmanmowerfreak
  • Senior Member
  • Member No: 16215
  • 258 Thanks
  • 222 posts
  • Location: Indiana

Posted March 02, 2015 - 07:58 PM

heres my other st10 its newer than yellow one according to serial numbers 

when i said someone put it together poorly is because trans was loose. and was missing bolts

 


Edited by craftsmanmowerfreak, March 02, 2015 - 08:26 PM.





Top