Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

I Need A Little Refresher.........


  • Please log in to reply
3 replies to this topic

#1 hamman ONLINE  

hamman

    Homelite Owner Extraordinaire

  • Senior Member
  • Contributor
  • Member No: 1733
  • 5,629 Thanks
  • 2,583 posts
  • Location: Michigan

Posted October 07, 2014 - 03:52 PM

course on checking the output of the Delco Remy starter generator on my Homelite. I just can't seem to figure it out. The book I have is lent out and my friend is gone hunting until next week. It may just be that the battery is to weak. I was tilling under the garden when the tiller didn't want to lift all the way. Now I did have to jump the battery to get it started but I figured the generator would put out enough to let me  till it. It's not that big. Going back put now to try it again. I do have three more SG if I need them.All were in good shape when put away.  Thanks for jogging the memory of this old man.                                                                    Roger.


  • New.Canadian.DB.Owner said thank you

#2 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,637 Thanks
  • 29,838 posts
  • Location: South Central Kentucky

Posted October 07, 2014 - 04:00 PM

Casey did an article on testing these.  You can find it HERE


  • Bill56, hamman, wvbuzzmaster and 4 others have said thanks

#3 Oldford OFFLINE  

Oldford
  • Senior Member
  • -GTt Supporter-
  • Member No: 50409
  • 802 Thanks
  • 572 posts
  • Location: n.e.

Posted October 07, 2014 - 10:03 PM

Before removing anything did you check voltage output while running?   I measured my s/g once it put out 15 volts on one pole, 11 on the other.  B+ on the reg should convert that to 13-14.  If you're getting 13+ at battery the charging system should be ok good luck


  • hamman said thank you

#4 hamman ONLINE  

hamman

    Homelite Owner Extraordinaire

  • Senior Member
  • Contributor
  • Member No: 1733
  • 5,629 Thanks
  • 2,583 posts
  • Location: Michigan

Posted October 08, 2014 - 08:30 AM

Going to do the checking today. I did a quick test yesterday and it showed it was putting out 14 (analog meter) at the B lug. Appears to be same at battery. More extensive today. Might be that the battery is getting weak. I can't remember the size the battery is supposed to be so I just bought a NAPA GT battery.  Thanks.                                                                                                                        Roger.






Top