Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Little Advice From The Experts Needed Please


  • Please log in to reply
2 replies to this topic

#1 StefC OFFLINE  

StefC
  • Member
  • Member No: 59856
  • 127 Thanks
  • 45 posts
  • Location: Pretoria, South Africa

Posted August 18, 2014 - 09:15 AM

Hi there

I am experiencing what is probably a well known problem but as a novice on the GT's I am at a disadvantage...

The hydraulics lift on my Hinomoto C172 is acting "down".

The arms move slowly down when required but refuses to come back up. When I manually "pump" the arms it seems to build enough pressure to stay up.

The Moto is the same as the Massey 1010. Maybe, just maybe I can get a pointer of where and what to look for?

Will only be able to attend to this problem at the end of August though.


Mogster

#2 boyscout862 OFFLINE  

boyscout862
  • Senior Member
  • Member No: 8923
  • 9,767 Thanks
  • 7,534 posts
  • Location: N.E. Connecticut

Posted August 18, 2014 - 12:36 PM

I would suspect fluid level or filter constriction first. The valve then becomes suspect. Try downloading this manual   http://gardentractor...-and1020wsmpdf/  if you don't already have it. Good Luck, Rick


  • TomLGT195 said thank you

#3 StefC OFFLINE  

StefC
  • Member
  • Member No: 59856
  • 127 Thanks
  • 45 posts
  • Location: Pretoria, South Africa

Posted August 18, 2014 - 01:01 PM

Thanks Rick, much appreciated. And nope do not have the manual, this will surely help a lot


Mogster




Top