Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

C-175 Issues


  • Please log in to reply
7 replies to this topic

#1 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted May 16, 2014 - 11:17 PM

Picked up a C-175 with blown KT17. It has plastic rear fender pan, gas tank under it. It is broken at corners. Anyone have one to sell and ship?  OR, someone told me I could put a tin fender panel on if find right one. Which is right model? Would need gas tank hole and think a dipstick hole, or guess could make new holes if careful. I'm also thinking of finding a Kohler single to put in if there are no big issues with alignment of shaft. This is one with a rubber mount engine platform, not a solid mounting to frame. OR, should I be looking for an 18 twin to drop into it? Harder to find those I belive, and more money when you do. Needs the clutch/brake pedal or whatever it is on left side. Was broken off at the top. Thinking it looks like most any of the C series pedal? 


  • New.Canadian.DB.Owner said thank you

#2 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted May 16, 2014 - 11:19 PM

Ooops! Forgot the pictures!

Attached Thumbnails

  • 2014-05-16 001.jpg
  • 2014-05-16 002.jpg

  • boyscout862 said thank you

#3 boyscout862 ONLINE  

boyscout862
  • Senior Member
  • Member No: 8923
  • 9,763 Thanks
  • 7,534 posts
  • Location: N.E. Connecticut

Posted May 17, 2014 - 05:30 AM

I've got the same problem with 2 old WHs. Let us know your solution. Good Luck, Rick



#4 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted May 17, 2014 - 03:14 PM

OK, messed with tractor some. Have engine out. This has the floating mount on biscuits. Opinions on if I can mount a single right on frame, just like older ones and have line up OK?  Bolt holes were drilled in frame looks like. See pix and look at the junk I wish to remove permanently, now off tractor. Have to get the hose out or pressure washer and clean up stuff. Also see the rear fender assembly I wish to replace, same part or metal if workable that way. I finally found the bolt to turn to let pressure off and push, but was hard to get too in there and then was square!! Only 5/16" and no way to crank it with small wrench. Finally got big adjustable to crack it loose and sometimes had to use small one to turn for access of big one. Anyway it rolled much better, and with air in tires was better. One front is leaking fast, so hope a tube will fix that! I'm going to hook my other wheelhorse pto up to belt and run up to this axle and see if it will run. Have done that before on others and works good. Seems to be turning right way by hand, but can't go fast and reverse didn't seem to work then. Cross my fingers it is good. Found the hole in block. Engine still turns over and one cylinder even has compression!  The one case cover was all unbolted from engine on pto side and lots of loose things just kinda loose fit back on, so someone has been into this before to examine.  Here's couple pix.

Attached Thumbnails

  • Wheelhorse and Sears from Portland 14 2014-05-17 003.jpg
  • Wheelhorse and Sears from Portland 14 2014-05-17 004.jpg
  • Wheelhorse and Sears from Portland 14 2014-05-17 005.jpg
  • Wheelhorse and Sears from Portland 14 2014-05-17 006.jpg
  • Wheelhorse and Sears from Portland 14 2014-05-17 007.jpg
  • Wheelhorse and Sears from Portland 14 2014-05-17 008.jpg
  • Wheelhorse and Sears from Portland 14 2014-05-17 009.jpg


#5 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted May 17, 2014 - 11:00 PM

Update:  Hooked my B-80 pto to the rear axle on this and it worked both ways! So, glad at least ONE thing works right on it. The lift worked fine also. The pressure release bolt goes in/out easier now that I have turned it and oiled some. Was told that metal fenders from 300, 400 and 500 models will fit on with no changes, so might be better to find those, than plastic that is not broken.



#6 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted May 23, 2014 - 02:51 PM

Got the metal yesterday and set on frame and looks just like it belongs there, so good on that. Had one front tire replaced with slightly smaller and fits wheel better, other one later. Got a pedal for it too and put it on and brakes are good now. Tore the engine apart and found one blown rod in many pieces, damage to block inside and the two holes in it! Have KT17 parts now, but not much in good ones. No good rods and pistons that everyone wants, but lots of small stuff. Still need to get out and scrape and power wash this thing, get it inside. Will be looking for an engine, hopefully a single K engine. Here's couple shots of metal on it. Later power-washed the whole rig and started bolting stuff back on for now. Has tailight covers on now and looks even better. Seat too.

Attached Thumbnails

  • Wheels and Horse and blade 2014-05-23 003.jpg
  • Wheels and Horse and blade 2014-05-23 004.jpg

Edited by glgrumpy, May 23, 2014 - 10:24 PM.


#7 Tankman OFFLINE  

Tankman
  • Senior Member
  • Member No: 21308
  • 294 Thanks
  • 295 posts
  • Location: Northeast Pennsy

Posted May 24, 2014 - 07:40 AM

Nothing to be grumpy 'bout except the previous owner......just didn't know or care.

 

Keep us updated, looks like you're movin' right along. Good luck!   :thumbs:



#8 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,652 Thanks
  • 6,469 posts
  • Location: Huntington, IN 46750 North East in State

Posted July 01, 2014 - 05:51 PM

Bought 14p Koehler today. Needs carb. Was from

GT14, so has correct clutch pulley, I hope. Won,t have underside mount holes like most Horse use, but will figure out a method. 4 my C175 if I lost yahoo.






Top