Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Modern Jd But I Could Sure Use Some Help!


  • Please log in to reply
5 replies to this topic

#1 gtcsreg OFFLINE  

gtcsreg
  • Senior Member
  • Member No: 25875
  • 1,666 Thanks
  • 1,649 posts
  • Location: Winchester, IL

Posted April 17, 2014 - 01:42 PM

Hey guys, I'm one of the Massey/Snapper GT guys but I mow with a JD X320 (22hp Kaw twin) 225hrs..  Having trouble getting it to start.  It will crank (brand new battery last week).  Put a kit in it recently (plugs, fuel and air filter, and oil & filter change).  After the kit I ran it about an hour with no problems and now it won't start.  She's getting gas as I can see it in fuel filter and removed air filter after I flooded it.  Checked the three fuses and they were ok.  PTO not engaged.  Lights come on.  Brake held down.  Taped down the seat safety switch to make sure that wasn't the problem.  Pulled both plugs to make sure they weren't fouled and they were ok.  Could NOT get spark.  Unplugged and plugged back all the wiring connections I could find.  HELP!  Any ideas?  Oh yeah, I taped the seat switch to see if I could see anything, does the drive belt spin when starting always?

 

Thanks, for any help you can give.

Reg

 

:tapping_fingers:



#2 glgrumpy OFFLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,668 Thanks
  • 6,486 posts
  • Location: Huntington, IN 46750 North East in State

Posted April 17, 2014 - 02:40 PM

Air pulse fuel pump on yours?  Older cracked hoses and at connections can leak vacumm.  The vac line from it to the crankcase get pulled off or bad?  Mine is Kohler twin, don't know Kawa's at all. Pto switch off? 



#3 gtcsreg OFFLINE  

gtcsreg
  • Senior Member
  • Member No: 25875
  • 1,666 Thanks
  • 1,649 posts
  • Location: Winchester, IL

Posted April 17, 2014 - 04:46 PM

Air pulse fuel pump on yours?  Older cracked hoses and at connections can leak vacumm.  The vac line from it to the crankcase get pulled off or bad?  Mine is Kohler twin, don't know Kawa's at all. Pto switch off? 

PTO off.  Hoses only just over four years old and look good.  After more research wondering if it's ECU (Electronic Control Unit).  Need to get my wife or daughter to sit on it and turn switch so I can confirm no spark.  $70 for part if it is grrrrrr!



#4 superaben OFFLINE  

superaben
  • Senior Member
  • Contributor
  • Member No: 11204
  • 7,664 Thanks
  • 5,677 posts
  • Location: Shenandoah Valley, VA

Posted April 17, 2014 - 08:17 PM

Your spark timer ("time delay") is toast.  It is a little black box next to the flywheel.  Your local Deere dealer should carry them, common as they are to break, last I bought one it was $20 something.

 

Ben W.



#5 gtcsreg OFFLINE  

gtcsreg
  • Senior Member
  • Member No: 25875
  • 1,666 Thanks
  • 1,649 posts
  • Location: Winchester, IL

Posted April 18, 2014 - 03:12 PM

It was the ECU.  $70 but I'm back up and running.  Thanks for the help guys! :smilewink:


  • Alc and Trav1s have said thanks

#6 Alc ONLINE  

Alc

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 1094
  • 5,459 Thanks
  • 6,629 posts
  • Location: Bangor Pa

Posted April 18, 2014 - 03:43 PM

Glad to hear you got the problem fixed
  • gtcsreg said thank you




Top