Jump to content

Garden Tractors and Parts on eBay



Photo
- - - - -

Hyd. Filter For 1010 Meteor


  • Please log in to reply
4 replies to this topic

#1 Danny McCloskey OFFLINE  

Danny McCloskey
  • Member
  • Member No: 14471
  • 16 Thanks
  • 11 posts
  • Location: Walton, In.

Posted February 01, 2014 - 05:15 PM

Does anyone know the number of the hydrostatic filter that is mounted on the firewall of the 1010 Meteor?  One of mine acts very weak when driving it, the other one responds quicker.  I took the number that is on the cover to my local NAPA, and they couldn't cross it over to anything they have.

 

Thanks

 

Danny McCloskey



#2 boyscout862 ONLINE  

boyscout862
  • Senior Member
  • Member No: 8923
  • 11,275 Thanks
  • 8,369 posts
  • Location: N.E. Connecticut

Posted February 01, 2014 - 05:33 PM

Welcome to GTT. Relax and enjoy the site. Someone will be along with your information. Check our manuals section too. 3 free downloads per day. Good Luck, Rick



#3 Canawler ONLINE  

Canawler

    Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 1273
  • 1,937 Thanks
  • 1,793 posts
  • Location: York, PA

Posted February 01, 2014 - 06:28 PM

Hydrostat filter is Napa 1487 or Fram C1678

 

Apparently its a very old number that hasn't been used in anything for quite some time.  My local Napa showed only one in stock at their warehouse and it was old packaging and covered with a very thick layer of dust.

 

It wouldn't hurt to change the fluid and filter but I doubt that's the cause of your trouble as the filter is in the reservoir.  I would look closely at the hydrostat belt tension.  Someone else recently mentioned sluggish performance and thought he had no belt slippage.  When he pushed on the belt while it was running he reported the tractor took off.


Edited by Canawler, February 01, 2014 - 06:33 PM.

  • sacsr said thank you

#4 Danny McCloskey OFFLINE  

Danny McCloskey
  • Member
  • Member No: 14471
  • 16 Thanks
  • 11 posts
  • Location: Walton, In.

Posted February 03, 2014 - 06:52 PM

Thanks for the information.  I thought it might help to change the filter and fluid.  The belt is new, with a strong spring on it.

 

Danny



#5 Canawler ONLINE  

Canawler

    Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 1273
  • 1,937 Thanks
  • 1,793 posts
  • Location: York, PA

Posted February 03, 2014 - 10:24 PM

I always forget to mention this one but make sure to fully close the bypass valve that allows the tractor to be pushed. If that's open a crack you would probably get the symptom you mentioned.




Top