Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

314 Sleeve Hitch


  • Please log in to reply
5 replies to this topic

#1 rainman_210 OFFLINE  

rainman_210
  • Member
  • Member No: 32663
  • 22 Thanks
  • 16 posts
  • Location: waupun wi

Posted June 09, 2013 - 08:45 AM

Hi fellas...bought a sleeve hitch for my 314...when i go to connect the lift rod to the lift shaft bracket on tractor the rod gets wedged up against the neutral detent bracket bolt on side of transaxle...am i sposed to bend the lift rod around that bolt?....thanks in advance for any advice2013-06-09_08-29-27_849.jpg 2013-06-09_08-29-43_526.jpg 2013-06-09_08-29-27_849.jpg
  • Texas Deere and Horse, larryd and JRJ have said thanks

#2 Texas Deere and Horse OFFLINE  

Texas Deere and Horse

    RED Wild Hogs, Horses & Deeres

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 1435
  • 14,464 Thanks
  • 15,392 posts
  • Location: East of San Antonio Texas

Posted June 09, 2013 - 11:43 AM

I maybe wrong, but that rod doesn't look like the right one. If you look at page #9 of this drawing, it has has all the dimensions for the right lift link.

 

http://gardentractor...-square-fender/


  • larryd said thank you

#3 Texas Deere and Horse OFFLINE  

Texas Deere and Horse

    RED Wild Hogs, Horses & Deeres

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 1435
  • 14,464 Thanks
  • 15,392 posts
  • Location: East of San Antonio Texas

Posted June 09, 2013 - 11:44 AM

Does the other end have a bend in it? Maybe you installed it backwards?


  • larryd said thank you

#4 xshooter OFFLINE  

xshooter

    Member

  • Member
  • Member No: 2325
  • 34 Thanks
  • 93 posts
  • Location: Lone Tree IA

Posted June 09, 2013 - 07:55 PM

It looks like you have a lift rod for an early 120/140. The newer tractors need one that has a bend in the front and the slot cut in at an angle.



#5 rainman_210 OFFLINE  

rainman_210
  • Member
  • Member No: 32663
  • 22 Thanks
  • 16 posts
  • Location: waupun wi

Posted June 09, 2013 - 09:18 PM

thanks texas and shooter....you both are correct I have the wrong lift rod



#6 Delmar ONLINE  

Delmar
  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 5039
  • 2,323 Thanks
  • 2,416 posts
  • Location: west central missouri

Posted June 09, 2013 - 11:29 PM

Here is a pic of the sleeve hitch lift arm/rod you need and a pic of it installed.

 

100_9549.jpg 100_9550.jpg






Top