Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

New to me JD330. Working out the bugs


  • Please log in to reply
16 replies to this topic

#1 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 26, 2010 - 10:01 AM

So far the starter has issues, not charging, transfer pump quit, hydro seems a little lazy to come up to speed but deck is in pretty good shape. Love the diesel, turns lot's of rpm's-- 3600+ as JD intended it to.

#2 olcowhand OFFLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,651 Thanks
  • 29,840 posts
  • Location: South Central Kentucky

Posted October 26, 2010 - 10:05 AM

Hey BIL...you're supposed to be working! LOL.......me too!

#3 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 26, 2010 - 08:24 PM

IMG00300-20101026-1958.jpg :smile1:

Attached Thumbnails

  • IMG00299-20101026-1958.jpg
  • IMG00301-20101026-2037.jpg


#4 olcowhand OFFLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,651 Thanks
  • 29,840 posts
  • Location: South Central Kentucky

Posted October 26, 2010 - 08:30 PM

:yelclap: Good deal!

#5 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 26, 2010 - 08:35 PM

Deck sounded great, seems the bearings are good. Lifted the back of the deck but not the front, one side of the rock shaft has been welded and cant be adjusted. Another bug to be worked out.:bump:

#6 ducky ONLINE  

ducky

    Senior Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 564
  • 1,631 Thanks
  • 3,870 posts
  • Location: Freedom, WI

Posted October 26, 2010 - 10:19 PM

That diesel looks as big as the 3 cylinder Thermo King I am putting in the 4855 Massey.

#7 NUTNDUN OFFLINE  

NUTNDUN

    Lost in Cyber Space

  • Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 3
  • 10,266 Thanks
  • 15,618 posts
  • Location: Pennsylvania

Posted October 27, 2010 - 06:03 PM

I love diesel. The 330 looks nice and clean. I am sure you will get all the bugs worked out.

#8 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 27, 2010 - 08:18 PM

Golden rule. check the easy things first:wallbanging: Starter had a loose connection on a slip on connector. Starts like a champ now:smile1: New filter on hydro but still lazy.

#9 mikebramel OFFLINE  

mikebramel

    Ron Paul

  • Senior Member
  • Member No: 82
  • 176 Thanks
  • 1,009 posts
  • Location: Milwaukee

Posted October 27, 2010 - 08:54 PM

Thats a nice looking machine

Are you going to try some 30w in the hydro

#10 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 28, 2010 - 09:23 AM

Thats a nice looking machine

Are you going to try some 30w in the hydro

Thanks. It acts like theres 90w in it! Almost like it shifts gears or something.

#11 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 28, 2010 - 09:24 AM

That diesel looks as big as the 3 cylinder Thermo King I am putting in the 4855 Massey.

Its a 3 cylinder yamar, and it fills all the space under the hood :)

#12 olcowhand OFFLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,651 Thanks
  • 29,840 posts
  • Location: South Central Kentucky

Posted October 28, 2010 - 10:31 AM

Thanks. It acts like theres 90w in it! Almost like it shifts gears or something.


One of my JB Bush Hogs does the same thing....takes off fine, but like a slipping clutch, then feels as it shifts to a higher gear. Both Fred's 330 and my JB pull great, strong as ever. Just on takeoff that they do it. My JB has a brand new old stock hydro unit, differential, and oil.
  • Meangreen said thank you

#13 Meangreen OFFLINE  

Meangreen

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 31
  • 94 Thanks
  • 300 posts

Posted October 28, 2010 - 09:08 PM

My 330 may be a cold start "Ether Baby" :( Not had time to check all the glow plugs yet. With just a small shot cold, she fired up with no violent noises. When warm, no problem...

#14 middleageddeere OFFLINE  

middleageddeere

    Tacos!

  • Senior Member
  • Member No: 2033
  • 243 Thanks
  • 1,082 posts
  • Location: MI

Posted February 13, 2011 - 09:25 PM

What is the hp on those?

#15 olcowhand OFFLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,651 Thanks
  • 29,840 posts
  • Location: South Central Kentucky

Posted February 13, 2011 - 09:39 PM

What is the hp on those?

16hp
  • middleageddeere said thank you




Top