Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Older MF 620 Snow Thrower


  • Please log in to reply
18 replies to this topic

#16 DH1 OFFLINE  

DH1

    Electric Tractors

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 62
  • 4,585 Thanks
  • 5,295 posts
  • Location: Markham Ontario Canada

Posted January 10, 2011 - 07:56 PM

My blower is just like the pic's you posted DH1. Does yours start running as you raise it up?


No it didn't the belt has a lot of slack in it, maybe your belt is 1 size too small???

#17 DH1 OFFLINE  

DH1

    Electric Tractors

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 62
  • 4,585 Thanks
  • 5,295 posts
  • Location: Markham Ontario Canada

Posted January 10, 2011 - 08:51 PM

There are 2 different snow blowers that have the drive belt go forward to the blower from the crank, very similar but the AGCO parts books show different drive belts for them.
1032843M1
1035690M1
What the difference is??? most likely length.

My blower attaches to a heavy bracket that bolts under the front of the frame to the front axle pivot bolt.
The other one attaches to a bracket that bolts to the front bumper.
Picture of my bracket.
SNOWBLOWER 007.jpg

#18 NYMalloys OFFLINE  

NYMalloys

    Tractorholic

  • Senior Member
  • Contributor
  • Member No: 126
  • 28 Thanks
  • 43 posts
  • Location: Ontario County, NY

Posted January 10, 2011 - 09:25 PM

I'm currently using the same type of MF 620 on my MF 12. I've had the issue you describe whenever I replace the drive belt. A new belt is tight and will engage when the thrower is lifted unless you adjust the "silver" metal arms to bring the upper portion of the thrower assembly closer to the tractor when it is off the ground. Shortening the length of the arms when in the up position should provide some slack.

#19 DH1 OFFLINE  

DH1

    Electric Tractors

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 62
  • 4,585 Thanks
  • 5,295 posts
  • Location: Markham Ontario Canada

Posted January 10, 2011 - 09:56 PM

attachments 002.jpg




Top