Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Loud Whirring Sound Fwd And Rev. Jac Gt16 +- 1975 Year


  • Please log in to reply
2 replies to this topic

#1 agreen6905 OFFLINE  

agreen6905
  • New Member
  • Member No: 32015
  • 1 Thanks
  • 1 posts
  • Location: Boise, ID

Posted April 01, 2013 - 09:05 PM

I recently nabbed a GT 16 off craigslist for free...great running little machine with tiller on back with pto. Wondering why when I press forward or back on the pedals it makes a really loud whirring sound until I am at full pedal. If I keep the pedal partially engaged it seems to skip or slip. I just topped off the hydro fluid and it didn't go away although the hydraulics got much stronger. (It was 1.5 qts low) Any pointers as to a good thread would be greatly appreciated! P.s. once the pedal is all the way down it doesn't make hardly any noise, just drives like a dream. :-)
  • Dieselcubmike said thank you

#2 Dieselcubmike OFFLINE  

Dieselcubmike
  • Senior Member
  • Member No: 11127
  • 1,327 Thanks
  • 1,511 posts
  • Location: Southwestern,Pa

Posted April 01, 2013 - 09:31 PM

First off welcome to GTtalk! :wave: got any pictures youd like to share with us? Though im not real good with hydros but it sounds like maybe the hydro might need rebuilt?



#3 poncho62 ONLINE  

poncho62
  • Senior Member
  • Member No: 42
  • 631 Thanks
  • 1,219 posts
  • Location: Hanover, Ont, Canada

Posted April 02, 2013 - 05:13 AM

I have 2 Ford LGTs with hydros....One whines like crazy, one doesnt. Both work well.....Seems this is a common complaint on these






Top