Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

20hp Sunstar Has No Hydraulics Or Drive


  • Please log in to reply
6 replies to this topic

#1 diesel nut ONLINE  

diesel nut
  • Senior Member
  • Member No: 7572
  • 496 Thanks
  • 316 posts

Posted March 20, 2013 - 12:59 PM

Hello all,  I have a 20 horse Sunstar that a customer brought into work that wont prime the hydro pump.  He had a leaking seal on the charge pump so he took the hydro off and brought it to someone else to have a new seal put in it.  When he got it back and reassembled it there was no leak but all the  hydraulics wouldnt work.  No power steering, no lift, and no drive.  I pulled the charge pump off thinking that when it was put back together they might have lost the pin for the rotor or maybe the pump might have broken as I've run into a few of them that did that before.  Everything was intact in the charge pump.  It had a Fram filter on it so I repaced it with one that was designed for those pumps.  When I took it off the filter was almost empty but there was oil coming out of the pump where the line from the rear end comes in and it was a pretty decent stream of it too.  I pulled the releif valves and swapped them with 2 known good ones thinking maybe they were weak or stuck internaly and got the same results.  As per the Sundstrand service book I put a gauge in and checked for pressure and there was nothing.  Going through the Simplicity service book I found the part about how to prime the pump so I jacked the rear end up as high as I could and tried it again and still nothing.  Any sugestions would be appreciated.  Thanks in advance.    Stewart



#2 New.Canadian.DB.Owner OFFLINE  

New.Canadian.DB.Owner
  • Senior Member
  • Contributor
  • Member No: 10178
  • 2,224 Thanks
  • 1,451 posts
  • Location: Trenton, Ontario, Canada

Posted March 20, 2013 - 01:54 PM

An empty filter suggests an airlock in the system.  Is this the transmission we are discussion?  Charge pump is item A?


  • diesel nut said thank you

#3 diesel nut ONLINE  

diesel nut
  • Senior Member
  • Member No: 7572
  • 496 Thanks
  • 316 posts

Posted March 20, 2013 - 02:00 PM

Yes thats the one. The parts in item A apear to be good.  I've also taken out both of item B and filled the ports with fluid to try and prime it that way with no luck and checked both item C and D to see if they were stuck or missing parts and everything is there and free


  • New.Canadian.DB.Owner said thank you

#4 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,637 Thanks
  • 29,838 posts
  • Location: South Central Kentucky

Posted March 20, 2013 - 02:22 PM

If the charge pump was rotated 180 degrees, then it won't pump.


  • sacsr, Michiganmobileman, CRFarnsworth and 3 others have said thanks

#5 diesel nut ONLINE  

diesel nut
  • Senior Member
  • Member No: 7572
  • 496 Thanks
  • 316 posts

Posted March 20, 2013 - 04:17 PM

If the charge pump was rotated 180 degrees, then it won't pump.

:wallbanging: Got it going.  That jogged my memory on something the owner said.  When he dropped it off he said that when he got the pump back from the other shop that the charge pump was on backwards from what the picture in the parts book showed. I just kind of figured he put it in and tried it first and when it didnt work he checked the book and saw that it was reversed from the picture and then switched it.  Guess I should have asked him that specificaly to begin with. :wallbanging:   So I checked 6 other tractors at work that have the same type of pump and dug out the really old Cub Cadet service book we have and sure enough the genuine Simplicity parts book shows the charge pump on backwards from the other tractors and service books that I have.  It works great now.  Thanks for the help.  Stewart


  • New.Canadian.DB.Owner said thank you

#6 chris m ONLINE  

chris m

    Tractorholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 8148
  • 3,277 Thanks
  • 4,033 posts
  • Location: Charlestown,Rhode Island

Posted March 20, 2013 - 05:21 PM

I had a feeling after I read your problem that Daniel would be the one who would know what was wrong with it. Glad you got it going. :thumbs:



#7 skunkhome OFFLINE  

skunkhome

    Member

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 8044
  • 322 Thanks
  • 455 posts
  • Location: Louisiana

Posted March 23, 2013 - 08:15 PM

Funny I just learned of that possibility an another forum just this week. How strange is that?




Top