Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Pk 2412 Starting Problem...i Need Help!


  • Please log in to reply
11 replies to this topic

#1 virginiacubfan OFFLINE  

virginiacubfan
  • Member
  • Member No: 10791
  • 51 Thanks
  • 43 posts
  • Location: Chester, VA

Posted March 19, 2013 - 07:27 PM

Hi everyone I need help!  I have a PK 2414 that rean fine until the other day when I left it outside overnight and now it wont turn over.  I have tried everything and I am stuck.  When I turn the key I lose power to the solenoid on the small terminal, I have a constant 12v to the main battery terminal.  When I turn the key to the on position I have about 7.5v and as soon as I turn the key to start I lose all voltage.  I have tried grounding the solenoid directly to the battery, but no success.  I just dont understand what could have happened overnight.  Any help would be much appreciated.  Thanks



#2 crittersf1 OFFLINE  

crittersf1

    GT Lunatic

  • Senior Member
  • Member No: 26142
  • 4,169 Thanks
  • 5,761 posts
  • Location: Newport, N.C.

Posted March 19, 2013 - 07:30 PM

Check the grounds and battery connections.



#3 Ryan313 OFFLINE  

Ryan313

    PK Fanatic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 7087
  • 3,239 Thanks
  • 5,159 posts
  • Location: Wallkill, NY

Posted March 19, 2013 - 07:37 PM

I don't think it would be the problem, but try giving your battery a good charge. And like said, check all of your connections.



#4 superaben OFFLINE  

superaben
  • Senior Member
  • Contributor
  • Member No: 11204
  • 7,664 Thanks
  • 5,677 posts
  • Location: Shenandoah Valley, VA

Posted March 19, 2013 - 07:40 PM

Critters is right: battery connections will cause you a problem overnight.  Don't just tighten them: take them apart and take a battery terminal cleaner or wire brush to both the terminal and the clamp.  After that, grounds, grounds, grounds!  I had a guy on an antique tractor forum who always used to say that automatically.

 

 

I don't know Power King tractors, so excuse my ignorance; is it battery ignition?  Ryan, set me straight.

 

Ben W.



#5 virginiacubfan OFFLINE  

virginiacubfan
  • Member
  • Member No: 10791
  • 51 Thanks
  • 43 posts
  • Location: Chester, VA

Posted March 19, 2013 - 07:46 PM

I am checking my grounds now...I just cleaned the terminals real good.  According to the manual the only ground they are showing is the battery to the frame and of course the solenoid to the frame.  It is a kohler k321 battery ignition.



#6 Jack OFFLINE  

Jack
  • Senior Member
  • Member No: 9304
  • 1,127 Thanks
  • 771 posts
  • Location: Fairfield Ohio

Posted March 19, 2013 - 07:52 PM

If you are dropping to 7.5 volts just turning on the key you have a dead battery.



#7 virginiacubfan OFFLINE  

virginiacubfan
  • Member
  • Member No: 10791
  • 51 Thanks
  • 43 posts
  • Location: Chester, VA

Posted March 19, 2013 - 07:57 PM

Thanks for the help I figured it out...weak battery and bad ground on solenoid!  Ben and Jack hit the nail on the head!  Thanks again everyone!!!!

 

Brian



#8 Ryan313 OFFLINE  

Ryan313

    PK Fanatic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 7087
  • 3,239 Thanks
  • 5,159 posts
  • Location: Wallkill, NY

Posted March 19, 2013 - 08:00 PM

Thanks for the help I figured it out...weak battery and bad ground on solenoid!  Ben and Jack hit the nail on the head!  Thanks again everyone!!!!

 

Brian

I am glad it is sorted out! Maybe you could post some pictures for us?



#9 virginiacubfan OFFLINE  

virginiacubfan
  • Member
  • Member No: 10791
  • 51 Thanks
  • 43 posts
  • Location: Chester, VA

Posted March 19, 2013 - 09:57 PM

A few pics with battery charging on the lift.

#10 virginiacubfan OFFLINE  

virginiacubfan
  • Member
  • Member No: 10791
  • 51 Thanks
  • 43 posts
  • Location: Chester, VA

Posted March 19, 2013 - 09:59 PM

A few pics with battery charging on the lift.

Attached Thumbnails

  • image.jpg
  • image.jpg


#11 virginiacubfan OFFLINE  

virginiacubfan
  • Member
  • Member No: 10791
  • 51 Thanks
  • 43 posts
  • Location: Chester, VA

Posted March 19, 2013 - 10:01 PM

Doing this from my iPhone is a little tricky. I don't know what happened in previous post with double pic .

Brian

Attached Thumbnails

  • image.jpg


#12 sep OFFLINE  

sep
  • Member
  • Member No: 25080
  • 60 Thanks
  • 65 posts
  • Location: CT/RI

Posted March 20, 2013 - 07:47 PM

Nice looking rig! What is that lift? Is it hydraulic? I need to get me a garage like that for my PK so I don't have to leave the bosses car outside in the cold. LOL!






Top