Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

Ariens Gt19 Interlock/time Delay

  • Please log in to reply
33 replies to this topic

#31 artbuc OFFLINE  



  • Senior Member
  • Member No: 1059
  • 69 Thanks
  • 151 posts

Posted June 04, 2014 - 11:23 AM

Ok, my parts are on order as I have confirmed my time delay module is faulty. Mine is a little different than the one Wm had (see post #17). The biggest difference is I do not have a D3 although there are holes in the circuit board where Wm shows it. Also my R1 is 6.8k, not 7.5k. Finally, my D1 is a TCI T6A40:


From what I have read, D3 is commonly called a snubber or flywheel diode used to protect the transistor from high transient voltages when the coil is de-energized. I believe the Ariens schematic is wrong here because it shows D3 in a direction that will not protect T1. Wm, your diagram and as-built original matches Ariens but you have not yet fried T1. I am not sure what to do. The correct placement of D3 should be across the relay coil so the output can flywheel back to the input when T1 switches off.



Hey Wm, I can not see how the ground gets connected from the circuit board to the metal can. It must somehow in order for the relay to ground through the red wire. Do you know how the circuit board and can are connected? Thanks.


Update: I checked by old Bosch relay and it indeed was diode protected which probably explains why my time delay module transistor (T1) did not fry. However, I have operated my PTO for 8-10 hours with a new relay which is not diode protected and the operation of the delay module did not change, ie it dropped out about 2 times per hour just like it did with the old relay. The installation of D3 as shown in the Service Manual and Wm's actual module will not do any harm but it will not do any good either, at least not in this application. Oh, I forgot to mention that my T1 is a MPS A06 which is capable of higher continuous base current.

Edited by artbuc, June 05, 2014 - 07:10 AM.

#32 dodge trucker ONLINE  

dodge trucker
  • Senior Member
  • Member No: 19314
  • 1,394 Thanks
  • 1,855 posts
  • Location: kankakee

Posted November 01, 2014 - 12:50 PM

Calling Wm... (hope youre still around, haven't seen you post in a while) 

Again  exactly what was your tractor doing that led you to this thing a ma jig, being bad? 

I too have a GT 19. You said yours is a model 931026.... mine is a 931029, IDK the difference between them.

Anyway mine has been sitting dormant for IDK how long, just got it.... I am trying to revive it.

I replacd the dash panel (because mine was bent up, right side portion was bent down/inwards when I brought it home), before I ever connected a battery. The only thing that I ever disconnected any wires from, was the ammeter so I could remove it from the old dash and put it into the new one. I unscrewed the rest of the switches and controls but never disconnected their wiring from them.


Since the battery that came with was 12 years old, totally flat, and these L&G batteries aren't known well for long life anyways I bought a brand new battery and put it in yesterday. The gas tank is out so I know it will not run but I wanted to crank the motor over to prime the hydraulic system so I could make sure it was full when I do run it so that nothing runs dry and "fries itself".


Anyways when I very 1st connected the battery it cranked just fine with the key. I was back n forth to the back of the machine topping off the fluid there.  I decided to splash some gas into the cab throat "just to see" if it would at least fire. nothing. So now I was between cranking, checking the ignition system (no spark) and topping off the hyd. fluid. 
Somewhere in there it stopped cranking with the key!  so I left the key on and used a screwdriver from that point on to jump the big lugs  on  the solenoid. I know the hour meter works because as I was fooling with the points and such it clicked over another hour.

Along with adjusting the points and cleaning them (I found out they were "stuck" closed and would not open) I ran a jumper from the battery "+" right to the coil "+".  Wow.  with the jumper direct from the battery to the coil it cranks with the key!  Disconnect that jumper and no cranking with the key.  I was not expecting that placing a jumper there would allow the key switch to work/not work..

I tried jumpering the ammeter, and nothing. still needed screwdriver across the solenoid. Only when I jumper the batt"+"to that yellow wire that feeds the coil "+" does the starter crank with the key...(I  can get to either end of that wire, the other end plugs into the ignition switch) . yet it cranked fine  without any jumpers required  anyplace, when I 1st put that new battery in.


I just retuned with nw points and condenser, am headed to the garage to see if "that" will fix the no spark issue with the engine and (I guess) check for dirty grounds. 


On the one side of the ammeter a purple wire comes off of it with an old glass style fuse holder.  While I had the dash panel off I pulled that fuse, it looked fine. What does that fuse control? It is a bit of a PITA to get at now with the dash all back in.


Also   since you said something about taking parts off of a "basket case GT17" I will send a PM (and hope you get it) to see if you may have a few pieces left on that machine that I could use for mine.

Edited by dodge trucker, November 01, 2014 - 12:52 PM.

#33 Wm McNett OFFLINE  

Wm McNett

    New Member

  • Senior Member
  • Member No: 1428
  • 85 Thanks
  • 132 posts
  • Location: Adrian, MI 49221

Posted November 01, 2014 - 04:04 PM

better check that fuse that you can't get to ;)

#34 dodge trucker ONLINE  

dodge trucker
  • Senior Member
  • Member No: 19314
  • 1,394 Thanks
  • 1,855 posts
  • Location: kankakee

Posted November 01, 2014 - 07:12 PM

it aint that fuse; IDK why it worked fine initially like it did, with nothing bypassed/     but I had to "temporarily" bypass the seat switch to get it to start by the key like it is, supposed to rather than having to use a screwdriver across the lugs of the solenoid... .while I have it jacked up for "debugging" (the seat and pan are off the tractor, I got it like that, because the lift cylinder was off the machine)

I did look at that fuse while I changed the dash panel, it was fine then;  but my lights do not work, I think the "hot" may have grounded itself out somewhere with the stuff that I have apart on this machine, so I'm thinking that this fuse may now be blown and that's why I have no power (verified by Fluke meter)  at any of the "hots" that feed the lights.  that is just a guess at this point....

oh and the ammeter does work, I did actually get this machine running today...

Edited by dodge trucker, November 01, 2014 - 07:16 PM.