Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

New Member To The Forum


  • Please log in to reply
25 replies to this topic

#1 RI LANDLORD 2012 OFFLINE  

RI LANDLORD 2012
  • Member
  • Contributor
  • Member No: 11139
  • 50 Thanks
  • 33 posts
  • Location: Wakefield, Rhode Island

Posted September 04, 2012 - 12:41 PM

Hello every one!! My name is Tom and, I own a 1966 Simplicity Landlord 2012 that my Grandfather bought new in December of 1966. I am semi-restoring it. I don't want to fully restore it because I use it for general yard work along with the trailer. I do not mow with it so, the mower deck has been fully restored. It even has the original mower blades that came from the factory. For some reason, my Grandfather took them off, wired them together and labled them,"factory blades won't hold an edge" I found them in a draw in his work bench. The tractor has always been garaged. Everything on it is tight. The 12 HP engine runs perfectly. The only items not original are the front tires, starter/generator, and the seat. Here are some photos:( Hope I can upload them)Posted Image Posted Image Posted Image

Edited by RI LANDLORD 2012, September 18, 2012 - 08:30 PM.


#2 HDWildBill OFFLINE  

HDWildBill

    Freedom is not Free. Thank those in uniform for your freedom.

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 6354
  • 8,697 Thanks
  • 8,555 posts
  • Location: Ga

Posted September 04, 2012 - 12:53 PM

Welcome to GTTalk Tom. Glad you decided to join us.

Only one image came through, that I can see. :(

#3 achomesteader OFFLINE  

achomesteader

    GT Fanatic

  • Senior Member
  • Contributor
  • Member No: 8128
  • 867 Thanks
  • 2,231 posts
  • Location: Winston-Salem, North Carolina

Posted September 04, 2012 - 01:13 PM

Welcome to GTtalk! Glad to have you with us.

That's a sharp looking 2012! :orangecool:

#4 daytime dave OFFLINE  

daytime dave

    Live long and prosper

  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 531
  • 4,485 Thanks
  • 6,353 posts
  • Location: Upstate NY

Posted September 04, 2012 - 01:27 PM

Welcome, that is a great Landlord. Glad you joined. I'll look forward to more photographs.

#5 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,393 Thanks
  • 39,654 posts
  • Location: Collinsville, Oklahoma

Posted September 04, 2012 - 01:52 PM

Welcome to the forum! I can see the last 2 of the images if I click on them. Nice looking GT you have there!

#6 RI LANDLORD 2012 OFFLINE  

RI LANDLORD 2012
  • Member
  • Contributor
  • Member No: 11139
  • 50 Thanks
  • 33 posts
  • Location: Wakefield, Rhode Island

Posted September 04, 2012 - 02:05 PM

Thank you for the kind words guys. . I will post more photos soon. I am waiting for the center arbor shaft to arrive this week so I can assemble the final arbor assembly and finish the deck. I assembled it with stainless hardware so the next time it has to come apart it will be much easier than when I did it!! Thank goodness for BB Blaster.
I am also a member of the DHS Die-Cast Forum (RI CRANEMAN)

#7 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,588 Thanks
  • 29,831 posts
  • Location: South Central Kentucky

Posted September 04, 2012 - 02:10 PM

Welcome to GTT! Great that you have your Grandpa's machine! I can't see any pics though.

#8 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,393 Thanks
  • 39,654 posts
  • Location: Collinsville, Oklahoma

Posted September 04, 2012 - 02:28 PM

I was trying to figure out how to get them fixed. If you click on either of the last 2, they show up. Would you save them, then edit and put them back in?

Somebody fixed them or something. The 2 show now!

Edited by KennyP, September 04, 2012 - 02:29 PM.
Added comment


#9 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,588 Thanks
  • 29,831 posts
  • Location: South Central Kentucky

Posted September 04, 2012 - 02:37 PM

I got one of them.

Attached Thumbnails

  • S.jpg


#10 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,588 Thanks
  • 29,831 posts
  • Location: South Central Kentucky

Posted September 04, 2012 - 02:38 PM

Another.

Attached Thumbnails

  • DECK3.jpg


#11 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,393 Thanks
  • 39,654 posts
  • Location: Collinsville, Oklahoma

Posted September 04, 2012 - 02:48 PM

They are in the original post now, Daniel!

#12 olcowhand ONLINE  

olcowhand

    Red Tractor Nut & Diesel Addict

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Sponsor
  • Contributor
  • Member No: 20
  • 35,588 Thanks
  • 29,831 posts
  • Location: South Central Kentucky

Posted September 04, 2012 - 02:55 PM

They are in the original post now, Daniel!


Not for me! I still can't see the one I didn't post.

#13 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,393 Thanks
  • 39,654 posts
  • Location: Collinsville, Oklahoma

Posted September 04, 2012 - 03:08 PM

I just took a screen shot!
RI LANDLORD.jpg

Only one showing now!


Went back to the top and 2 pics were showing:
RI LANDLORD2.jpg

What the heck is going on here!

#14 achomesteader OFFLINE  

achomesteader

    GT Fanatic

  • Senior Member
  • Contributor
  • Member No: 8128
  • 867 Thanks
  • 2,231 posts
  • Location: Winston-Salem, North Carolina

Posted September 04, 2012 - 03:30 PM

I just took a screen shot!
RI LANDLORD.jpg

Only one showing now!


Went back to the top and 2 pics were showing:
RI LANDLORD2.jpg

What the heck is going on here!


I've seen this happen many times. The fault lies at photobucket.
  • KennyP said thank you

#15 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,393 Thanks
  • 39,654 posts
  • Location: Collinsville, Oklahoma

Posted September 04, 2012 - 03:35 PM

Thanks, Greg! First, no pics. Then both. Then none! Had me scratching body parts trying to figure out what was going on!




Top