Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

Viking 16hp - Briggs Has No Spark

  • Please log in to reply
3 replies to this topic

#1 motobreeder OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 3989
  • 425 Thanks
  • 611 posts
  • Location: Eastern Ontario

Posted July 12, 2012 - 11:15 PM

A few weeks ago when I bought the tractor, there was a spark - it would run but needed 1/2 choke.
Tonight I finally got around to cleaning up the carb and now there's no spark.

It's a 1972, 16HP briggs with magneto ignition and external points.

Tried a few different plugs.
Removed the kill wire.

Any high probability suggestions? I find it odd that the coil may have failed.
I'm looking at the number of pieces that have to come off to get at the magneto and I don't have a spare one to try.

Is there any way to test the coil? High tension winding resistance?





  • Senior Member
  • Member No: 4343
  • 409 Thanks
  • 482 posts
  • Location: YORK,PA

Posted July 13, 2012 - 02:54 AM

Are you getting current through your points ?
Try re-setting the points and taking some fine sand paper through the points[ be careful the points are only held in place by a tab and spring tension, and pop out if you look at them crooked ] then run a clean piece of paper money through to clean points.
Sometimes they can be contemptable in high humidity.

#3 AverageJoe OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 365
  • 104 Thanks
  • 142 posts
  • Location: Virginia

Posted July 27, 2012 - 10:19 PM

Check the air gap of the coil to flywheel (business card width). Recheck the points as halfscale mentioned. Verify the wiring was not damaged when you rebuilt the carb.

These engines do not produce the greatest spark at lower RPMs, so you may never see a visible spark. I had two engines like this with no visible spark, but they both started and ran.
  • Texas Deere and Horse and motobreeder have said thanks

#4 EricFromPa OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 2135
  • 2,170 Thanks
  • 2,250 posts
  • Location: Bedford County Pa.

Posted August 22, 2012 - 04:35 PM

You can put an Electronic ignition coil in her but You will have to pull the engine.Those 16hp Cast Briggs are HEAVY!!!
The cheaper,easier fix would be to replace the condenser and Clean and re-gap the points.

Condensers are around $12 and an electronic ignition coil is around $45 off of Ebay.
  • motobreeder said thank you