Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Runs/drives! Needs Adjustment?


  • Please log in to reply
5 replies to this topic

#1 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,667 Thanks
  • 6,486 posts
  • Location: Huntington, IN 46750 North East in State

Posted June 28, 2012 - 08:47 PM

Charger Electro runs/drives. At first thought NOT, then tried the push valve turned around and wanted to take off! Have problem that Nuetral is very hard to find. Real touchy. The pedal kicks it into N, but still creeps, even while holding it down. Is there adjustment? I loosened the ball that raises the control thinking it was slotted, but it's not. Is there another slotted link? OR, is tomething to be done in that plastic control part that goes up/down? Should that be greased or something? Seems to slide fine now, but is dry. Drove around quite a bit today, works good both directions, goes plenty fast if you want or holds a steady slower speed. Having issues with pto working, the key switch seems to be shot, can wiggle it around and get stuff to work off/on. It had a broken term on it, which I fixed steady, but must still be bad connetions inside. Anyone have one like it? I'll have to wait for manual to get actual part number for it. Seems to be diff than many.

#2 Texas Deere and Horse OFFLINE  

Texas Deere and Horse

    RED Wild Hogs, Horses & Deeres

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 1435
  • 14,464 Thanks
  • 15,392 posts
  • Location: East of San Antonio Texas

Posted June 28, 2012 - 08:58 PM

GL, Did you download a manual from here? In the service manual, it tells you in great detail how to adjust the neutral position.
  • MH81 said thank you

#3 MH81 ONLINE  

MH81

    Proud to be Deplorable

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 802
  • 27,335 Thanks
  • 28,642 posts
  • Location: N. W. PA

Posted June 28, 2012 - 09:03 PM

Brian, do you have a link to that manual? I didn't see anything for Electro...

Is it the BCD Service manual?

#4 Texas Deere and Horse OFFLINE  

Texas Deere and Horse

    RED Wild Hogs, Horses & Deeres

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 1435
  • 14,464 Thanks
  • 15,392 posts
  • Location: East of San Antonio Texas

Posted June 28, 2012 - 09:17 PM

Brian, do you have a link to that manual? I didn't see anything for Electro...

Is it the BCD Service manual?


No, we don't have it, but I think I have one to send him.

GL, I sent you a PM..
  • MH81 said thank you

#5 glgrumpy ONLINE  

glgrumpy

    Getting Out!

  • Senior Member
  • -GTt Supporter-
  • Member No: 8360
  • 6,667 Thanks
  • 6,486 posts
  • Location: Huntington, IN 46750 North East in State

Posted June 30, 2012 - 11:14 PM

Thanks guys! Got your info's in email and also Sat got my Electro manual from epay. Real nice book. Got it adjusted tonight, very touchy! Didn't seem to want to stay the same each time. Finally now have it good enough to set and run/idle for quite awhile. I greased the sliders and ball and the pedal cam. Didn't see anywhere to do that, just seemed right. DID make me have to reset it again with the difference. Is the grease gonna be a problem?

#6 Cvans ONLINE  

Cvans

    Tractorholic

  • Senior Member
  • -GTt Supporter-
  • Member No: 5412
  • 4,522 Thanks
  • 5,033 posts
  • Location: Eastern SD.

Posted June 30, 2012 - 11:20 PM

Is the grease gonna be a problem?

Only if it accumulates enough dirt and crud to gum things up. Next time you might want to try spray on graphite. Excellent lubricant that dries and will not attract dirt and crud.
  • MH81 said thank you




Top