Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay



Photo
- - - - -

Mower Blades- Time To Change?


  • Please log in to reply
4 replies to this topic

#1 dogsoldier OFFLINE  

dogsoldier
  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 9589
  • 316 Thanks
  • 490 posts
  • Location: mt union pa

Posted June 04, 2012 - 03:06 PM

the blades on the wheelhorse i got needed new blades when i got it and i knew it. when i mowed it left a 3 inch path behind in the center of the deck from the blades being wore out. i got my new blades that i ordered from amazon a few days ago.
here are a couple pics of old and new blades.
2012-06-04_13-54-03_76.jpg

2012-06-04_13-54-12_568.jpg

#2 KennyP ONLINE  

KennyP

    FORDoholic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 2253
  • 28,409 Thanks
  • 39,663 posts
  • Location: Collinsville, Oklahoma

Posted June 04, 2012 - 03:26 PM

Looks like the old ones were never sharpened correctly. Bet they are out of balance bad!

#3 dogsoldier OFFLINE  

dogsoldier
  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 9589
  • 316 Thanks
  • 490 posts
  • Location: mt union pa

Posted June 04, 2012 - 03:46 PM

believe it on not but when i took the blades off i thought the same thing so i checked them. they was right on the money. i put these blades on this very mower about 6 years ago and i know he never did anything with them but have someone sharpen them a couple months ago. then he bought another mower and i bought this one.

#4 Ryan313 OFFLINE  

Ryan313

    PK Fanatic

  • Super Moderator
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 7087
  • 3,239 Thanks
  • 5,159 posts
  • Location: Wallkill, NY

Posted June 04, 2012 - 04:35 PM

I wonder what would cause that, it's definitely now normal wear. I wouldn't be surprised if you felt a lot less vibration when mowing. LOL!

#5 dogsoldier OFFLINE  

dogsoldier
  • Senior Member
  • -GTt Supporter-
  • Contributor
  • Member No: 9589
  • 316 Thanks
  • 490 posts
  • Location: mt union pa

Posted June 04, 2012 - 05:02 PM

it really didnt vibrate all that much before but i will say it cuts better.
as for what caused it- besides the blades being 6 years old and the PO ran over everything i have no idea.




Top