Jump to content

Vote for Tractor of the Month
Garden Tractors and Parts on eBay

- - - - -

qt-17 hydraulic lift doen't work

  • Please log in to reply
2 replies to this topic

#1 bridgtonbolens OFFLINE  


    New Member

  • New Member
  • Contributor
  • Member No: 561
  • 3 Thanks
  • 8 posts
  • Location: Bridgton, ME

Posted June 01, 2010 - 06:43 AM

Morning folks,

I have a Qt-17 and the hydraulic lift stopped working. When I move the control handle I can see the piston tryes to move. I unhooked the brackets from the piston thinking the brackets might be stuck and the piston with nothing attachrd to it still does not move. So I than removed the piston and I can pull an push the ram in and out. The ram is in fine shape with out and scars or dings and it does leak. Next I put it all back together in hope that it would work. but its still doen not move in and out. I also replaced the filter. Any thought on what I should try next.



#2 Bolens 1000 ONLINE  

Bolens 1000

    DR. Bolens

  • Staff Admin
  • Staff
  • -GTt Supporter-
  • Contributor
  • Member No: 7
  • 12,446 Thanks
  • 17,087 posts
  • Location: Western NY

Posted June 01, 2010 - 03:06 PM

Welcome to the forum, bridgtonbolens :welcometogttalk:
There are many Friendly and knowledgable people here at GTT!

I'm not too good with Hydrolics, so I'll leave this question for someone with more experience with it to answer this.

Also, we love pictures here, so if you have any pictures of your Bolens we would love to see them :wave::wewantpics:

#3 mjodrey OFFLINE  



  • Senior Member
  • Contributor
  • Member No: 92
  • 2,343 Thanks
  • 13,481 posts
  • Location: Upper Granville, Nova Scotia, Canada

Posted June 01, 2010 - 03:12 PM

bridgtonbolens,glad to have you here.