Jump to content

Nominations for Tractor of the Month
Garden Tractors and Parts on eBay




Recent Comments


Upcoming Events


Latest Classifieds

* * * * *

Taking care of your Delco Remy Starter Generators

delco-remy bolens cub cadet garden tractor starter regulator


7 Comments

Excellent points all around.  Since most folks are used to their car's alternator, a starter generator is one of the things people forget to maintenance. 

    • Bolens 1000, boyscout862 and MrMarty51 have said thanks

Nice article. This manual has a lot of info on the regulators also.

    • chris m, boyscout862, alec and 1 other said thanks
Photo
Bolens 1000
Feb 01, 2015 05:07 PM

Thanks Kenny!

I have the old outdated version of this one, I like this much better!

    • boyscout862 and MrMarty51 have said thanks

Thank You very much for this information.

This will be a big help in the future.

It seems that the P.O. of my JD 110 was not so kind to this starter generator, it is all burned up inside.

Bearings are shot, armature is burned bad and one side of the field windings are toast.

It looks to be that there are some after market units available, are they worth installing ?

Also, there are some parts for sale on the various websites. Would it be worth spending about $150.00 on the field winding, armature, brushes and bearings to rebuild this one or would You members think it better to get a reman or an aftermarket ?

Curious too, if the internal components of the aftermarket would fully interchange into the old Delco case.

At least with that, it would look original.

OH YEAH ! also. The mounting holes on the generator/starters ears are wobbled out a bit. The nut was completely gone that pinches the ears onto the mounting bracket.

I know, this is an old thread, Just did a search and here it was, instead of firing up a new thread.

I know this is reviving an old thread, I may have been better off starting a new thread but this one was alreeady here soooo.

The Delco 1101970 starter generator on My JD110 was completely toast on the insides.

I got a new Delco Remy armature that has the same numbers as the old unit. I got the new windings, Lemans, or something, very nice, made in Canada.

I got the unit back together, the pole shoes would not allow the armature to fit so I removed the field windings and installed just the new pole shoes, still no fit. I ground off a bit of the shoes bases, just enough to allow the armature to fit nicely, no drag at all with bearings and end caps on.

I assembled the unit but I had the field and armature terminals in the wrong positions, hooked it to a battery to test the mortoring. I got a big spark, took it apart, switched positions with the terminals, assembled, hooked it to the battery, A terminal on pos, grounded the case, no motoring, hooked a ground to the field terminal and still no motoring.

I did have a slight spark when I hooked the ground wire to the case. I did try spinning the pulley but it still would not run.

Anyone ever had a problem such as this ?

I hope I did not fry something by having the terminals in the wrong positions.

The battery is fully charged as evidenced by the big spark when terminals was backwards.

HELP !

OH yes, also, there was no magnetism at all on the pole shoes. I am not sure if they need magnetism to make the starter/generator function.

Photo
crazy4bolens
Sep 05, 2016 03:48 PM

 Very helpful, Thank you!

    • MrMarty51 said thank you
Top